Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
New Developer
orgicus
Posts: 5
Registered: ‎03-14-2011
My Device: Playbook

Problem running OpenGL in Simulator

Hello,

 

I'm having a hard time setting up for BB development on OSX.

The Simulator is for Windows only, so I've tried a few options:

- tried running the simulator on OSX using wine and winetricks, but couldn't get it to run

- installed XP on VirtualBox, enabled 3D acceleration, but the simulator interface flickers a lot

and OpenGL content does not render (I see black screen)

- installed XP on vmware with 3D acceleration enabled: the simulator runs but does not render OpenGL

- installed XP on Parallels and the simulator only runs in software mode

 

What setup do I need to run OpenGL content in the Simulator ?

 

I'm using BB Java SDK 7.0 with Simulator 7.0.0.261 for 9930.

 

Any advice will help

Please use plain text.
BlackBerry Development Advisor
MSohm
Posts: 14,685
Registered: ‎07-09-2008
My Device: BlackBerry Z30, BlackBerry PlayBook

Re: Problem running OpenGL in Simulator

You need at least OpenGL2.1+ support (video card and driver), with about 64mb of vram.

 

The BlackBerry smartphone simulators do not currently support MacOS though.  

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
Please use plain text.