Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
New Contributor
julykillua22
Posts: 8
Registered: ‎03-29-2011
My Device: 9800

Purged 1 stale user setting entries.

My BB Torch sometimes takes so long to process data.  I am currently developing an application and when I connected the phone to the computer and check what's going on, it shows this message constantly:

 

 

Purged 1 stale user setting entries. 20515 ms.
Purged 1 stale user setting entries. 15806 ms.
VM:NCICv=53
VM:NMACv=10
Purged 1 stale user setting entries. 15823 ms.
Purged 1 stale user setting entries. 16216 ms.
KEYNEGO:->:ERR:4607:smileyfrustrated:ervice blocked
BbiAuth:TokenDenied
SSL:->CH
SSL:->CH
SSL:->CH
Purged 1 stale user setting entries. 17770 ms.

 

Purged 1 stale user setting entries. 20515 ms.Purged 1 stale user setting entries. 15806 ms.VM:NCICv=53VM:NMACv=10Purged 1 stale user setting entries. 15823 ms.Purged 1 stale user setting entries. 16216 ms.KEYNEGO:->:ERR:4607:smileyfrustrated:ervice blockedBbiAuth:TokenDeniedSSL:->CHSSL:->CHSSL:->CHPurged 1 stale user setting entries. 17770 ms.

 

This doesn't always occur by the way.  It happens randomly.  It looks to me that the platform is doing Garbage collection, but I'm not sure.  

 

Any ideas what's wrong?

Please use plain text.
New Contributor
julykillua22
Posts: 8
Registered: ‎03-29-2011
My Device: 9800

Re: Purged 1 stale user setting entries.

I tested this on Bold and it also happens randomly.  Anyone encountered this same issue?

Please use plain text.
New Contributor
julykillua22
Posts: 8
Registered: ‎03-29-2011
My Device: 9800

Re: Purged 1 stale user setting entries.

any insights? o_o

Please use plain text.
Developer
RileyGB
Posts: 284
Registered: ‎08-06-2010
My Device: Z10

Re: Purged 1 stale user setting entries.

I'm getting this too. I have no clue why it happens nor how I can fix it.



Follow me on twitter @RileyGB - https://twitter.com/RileyGB
View my BB10 OpenSource projects - https://github.com/RileyGB/BlackBerry10-Samples
Please use plain text.
New Contributor
FarhanWasim
Posts: 7
Registered: ‎03-14-2013
My Device: Blackberry Style

Re: Purged 1 stale user setting entries.

Anyone found any solution to this? I am facing the same problem.....
Please use plain text.
Developer
peter_strange
Posts: 19,603
Registered: ‎07-14-2008
My Device: Not Specified

Re: Purged 1 stale user setting entries.

Looking at this error log, the issue would seem to be related to a SSL connection.  Is your application attempting to communicate with a Server using Https or some secure socket connection at the time of the problem?

Please use plain text.
New Contributor
FarhanWasim
Posts: 7
Registered: ‎03-14-2013
My Device: Blackberry Style

Re: Purged 1 stale user setting entries.

The application that I am working on does not involve any network connections. However it involves getting GPS data. However, I see this message even before the application starts up(usually I try to launch the app, this message shows up and the app never launches). There is this other post about this error message over here: http://supportforums.blackberry.com/t5/Java-Development/Purging-stale-user-setting-entries/td-p/1248...
Someone on that post suggested that it might be a memory issue, and I have the same feeling(mind you, this happens randomly)
Please use plain text.
Developer
peter_strange
Posts: 19,603
Registered: ‎07-14-2008
My Device: Not Specified

Re: Purged 1 stale user setting entries.

OK, given that it is not a networking issue, then the one thing that GPS location and network communication have in common, is the length of time that they can take.  I suggest that you comment out the request for a location (supply a dummy location perhaps to get your app going) and see if the problem disappears. 

Please use plain text.
New Contributor
FarhanWasim
Posts: 7
Registered: ‎03-14-2013
My Device: Blackberry Style

Re: Purged 1 stale user setting entries.

I tried commenting out the instantiation of the class itself responsible for creating the location providers and requesting the location updates, but it still shows the same message. It would greatly help if the people who encountered the same problem could share their experience of how they got over it....
Please use plain text.
Developer
peter_strange
Posts: 19,603
Registered: ‎07-14-2008
My Device: Not Specified

Re: Purged 1 stale user setting entries.

But are they still active?  The OP on this Thread has not been round for over 1 year!

Please use plain text.