Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
Posts: 59
Registered: ‎06-15-2012
My Device: 9800
My Carrier: XZY
Accepted Solution

Regarding Simulator Help ( Please its urgent)

HI.
           I have application which is running fine on blackberry smartphone 9800 simulatore as well device also.but now i have to test that application on os 7 but  there no simulotre avilable for smartphone 9800 which support os 7. so if i download 9810 simulatore  will it work on 9800 device ??. Please give idea about this. i am using eclips
i have jre 6.0 and jre 7.0 and when i choos jre 7 then it ruuning 9930 simulator which giving app error to me
please any help
thanks in advance
Developer
Posts: 19,628
Registered: ‎07-14-2008
My Device: Not Specified

Re: Regarding Simulator Help ( Please its urgent)

"there no simulotre avilable for smartphone 9800 which support os 7" 

Correct, there is no OS 7.0 for the 9800, it is not supported on that device.  So if yo uwant to test OS 7, you will have to use a different device (both Simualtor and real device). 

 

"if i download 9810 simulatore  will it work on 9800 device"

No.

 

" have jre 6.0 and jre 7.0"

If yo uwant tyou app to be supported on OS 6.0 and above, stock with 6.0. 

 

"when i choos jre 7 then it ruuning 9930 simulator which giving app error to me"

Note the above.  That said, applicatins should be forward compatible.  You might like to look at this problem to see if in fact it is a real problem that is only showing up on the later devices. 

 

We can't really help investigate a problem with a descriptin like "giving app error to me".  If you want us to help with this problem you will need to give additional information describing the problem in more detail. 

Developer
Posts: 59
Registered: ‎06-15-2012
My Device: 9800
My Carrier: XZY

Re: Regarding Simulator Help ( Please its urgent)

Hey Peter thnanks for reply

 

As you r saying that " there is no OS 7.0 for the 9800, it is not supported on that device" mean if i want to install os 7 on my blackberry tourch smartphone 9800  it will not support ?(mean not allowed to install). ??

 

and regarding the error problem. i am getting  App Err 104  uncaught : classcastException . while ruuning the simulatore. i think this could be a casting problem . but why it is working on simulatore 9800 and device without any error . can tell me about that

 

Developer
Posts: 19,628
Registered: ‎07-14-2008
My Device: Not Specified

Re: Regarding Simulator Help ( Please its urgent)

"i want to install os 7 on my blackberry tourch smartphone 9800  it will not support ?(mean not allowed to install). ??"

 

In BlackBerry land, OSs are specific to each device, so you do not get OS 7.0 and install it on any device, instead you get OS 7.0 for the device you want to install it on and install it on that device, and that device only. 

 

I am not aware of RIM releasing OS 7.0 for the 9800, so you will not be able to find an OS 7.0 for that device, which means you can't upgrade it to OS 7.0. 

 

This is different to things like Windows, where you buy the OS and can install it anyway you like. 

 

Is that clear now? 

 

" App Err 104  uncaught : classcastException . While running the simulators"

 

This is still not enough information for us to help you.  If I told you my PC Java program was getting a class cast exception, would you be able to tell me what is wrong?

 

But you should not need our help with this.  If you debug this, you should be able to find this problem yourself. 

 

Good luck.

Developer
Posts: 59
Registered: ‎06-15-2012
My Device: 9800
My Carrier: XZY

Re: Regarding Simulator Help ( Please its urgent)

Hey Thanks ,

 

now i understood os related problem thanks peter.

 

and regarding classcast exception i found the problem 

EncodedImage encImg = GIFEncodedImage.getEncodedImageResource(" resource file..");

GIFEncodedImage img = (GIFEncodedImage)encImg;  --> this line causing the exception. i tried in diffrent way but :smileysad:

if u give any idea about it. would be appreciate.

Developer
Posts: 19,628
Registered: ‎07-14-2008
My Device: Not Specified

Re: Regarding Simulator Help ( Please its urgent)

Is the encoded image really a gif - the failure indicates it is not. 

 

If you really want a gif, open it in some drawing package, save it again, making sure you specify gof, and try again.

 

Alternatively, there could be a bug in the gif decoding in a later OS.  I never use GIF's so won't hit this if there was a problem like this.  Try PNG or JPG. 

Developer
Posts: 59
Registered: ‎06-15-2012
My Device: 9800
My Carrier: XZY

Re: Regarding Simulator Help ( Please its urgent)

Hey Peter

                    i got solution for that and it is working ..

 Thanks peter.

Developer
Posts: 19,628
Registered: ‎07-14-2008
My Device: Not Specified

Re: Regarding Simulator Help ( Please its urgent)

Great.

 

Can you mark this as solved?  Instructions in Help link near the top of the screen.  Thanks