Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
shreyasb
Posts: 152
Registered: ‎07-17-2009
My Device: Not Specified

RenderingSession returns null

[ Edited ]

i want to develope appli which has browserfield to browse any url.

 

i m using bowserfield class method from in built JDE example.

 

in this method i m using

_renderingSession = RenderingSession.getNewInstance();

 

but this line returns null while using on real device (curve 8520).

 

but it is working fine on simulator.

 

 in addition:-

 

i m facing this problem on wi-fi connection only.

direct tcp with (airtel) working fine.

but i get null value while using wi-fi connection only.

same URL i opened with blackberry browser with wi-fi its working fine.

but working with browser field ...its giving null value.

 

sample jde browser cod i deployed in device...same problem exists.

its working with airtel but not working with wi-fi.

help me out

Developer
developing
Posts: 33
Registered: ‎05-08-2009
My Device: Not Specified

Re: RenderingSession returns null

Please check your apn settings(It should correspond to the carrier and blackberry.net won't work unless you are a alliance member

Developer
shreyasb
Posts: 152
Registered: ‎07-17-2009
My Device: Not Specified

Re: RenderingSession returns null

i m facing this problem on wi-fi connection only.

direct tcp with (airtel) working fine.

but i get null value while using wi-fi connection only.

same URL i opened with blackberry browser with wi-fi its working fine.

but working with browser field ...its giving null value.

 

sample jde browser cod i deployed in device...same problem exists.

its working with airtel but not working with wi-fi.

help me out

Developer
developing
Posts: 33
Registered: ‎05-08-2009
My Device: Not Specified

Re: RenderingSession returns null

Hi,

 

It should ideally take you through the wi-fi mode also. Just try appending "interface = wifi" in your URL and check if that works.

Developer
shreyasb
Posts: 152
Registered: ‎07-17-2009
My Device: Not Specified

Re: RenderingSession returns null

thanks for the reply

 

i already appened interface = wifi in my url...

all other function works well with wi-fi.

only browser field doesn't work.

Developer
developing
Posts: 33
Registered: ‎05-08-2009
My Device: Not Specified

Re: RenderingSession returns null

can you give the code sample that you are using? Did you check if other third party applications work on Wi-Fi on that device? Is the device you are using connected to BES?