Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Contributor
ferry_new2004
Posts: 16
Registered: ‎01-18-2011
My Device: 9800

Scanning barcode 2D

Hi guys, I have a problem where scanning barcode 2D in Blackberry  8530 OS v 5.0.0.973  doesn't work (cannot scan Barcode 2D at all) while  the same code of program (the same COD file) can work well in different Blackberry OS5 ( I forget what version it is) and Blackberry Torch OS6.

 

The lines of code is basically the same with the example in blackbery websites.

 


Hashtable hints = new Hashtable(1);
Vector formats = new Vector(1);

formats.addElement(BarcodeFormat.QR_CODE); // You can change format
// here
hints.put(DecodeHintType.POSSIBLE_FORMATS, formats);
decoder = new BarcodeDecoder(hints);

 

 

I have made sure that it is not about the quality of the barcode 2D printout. The print quality is excellent but the   Blackberry  8530 OS v 5.0.0.973   cannot scan any barcode 2D.

Does any one know what is the problem ?

Thank you.

 

Regards,

Ferry

Please use plain text.
Contributor
ferry_new2004
Posts: 16
Registered: ‎01-18-2011
My Device: 9800

Re: Scanning barcode 2D

I forget to add information. With the same COD file, I tested and found :

The  Blackberry  8530 OS v 5.0.0.973  CDMA cellular smartphone cannot scan any barcode 2D while 

The  Blackberry  8530 OS v 5.x.x.x GSM cellular smartphone can scan barcode 2D.

The  Blackberry  Torch OS v 6.x.x.x GSM cellular smartphone can scan barcode 2D.

 

Does CDMA or GSM criteria take part in scanning barcode 2D ?

Thank you.

 

Regards,

Ferry

 

 

 

 

Please use plain text.
Developer
peter_strange
Posts: 19,608
Registered: ‎07-14-2008
My Device: Not Specified

Re: Scanning barcode 2D

As I understand it, BarcodeDecoder is not officially supported in OS 5.0 at all, however it would appear that the support has somehow got into OS 5.0 for some releases.  But what that means to you is that you can not install this code on any OS 5.0 device and be sure that it will work.   I think the GSM/CDMA thing is just a coincidence.

 

If you want this sort of scanning in your OS 5.0 app, then I think you can include the zxing code directly yourself. 

Please use plain text.