Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
Raiden
Posts: 490
Registered: ‎07-16-2008
My Device: Not Specified
Accepted Solution

Send Mail sample application

Hello guys'

 

If you have send email sample source cod, help me to give.

I need to send mail for my developing application. 

 

Tnx for ur support :smileyhappy:

 

Please use plain text.
Developer
peter_strange
Posts: 19,599
Registered: ‎07-14-2008
My Device: Not Specified

Re: Send Mail sample application

There are a number of resources that I suggest you review, prior to asking a question on the forum.  I would recommend the following:

 

http://na.blackberry.com/eng/developers/

 

Look at all the options under Resources.  Especially useful when needing a code fragment like this, is the Knowledge Base, available from the "Developer Support" link under Community from the above or directly:

 

http://www.blackberry.com/knowledgecenterpublic/livelink.exe

 

In there, I did a quick search and found the following, which I think answers your question:

 

How To - Create and send messages
Article Number: DB-00433

http://www.blackberry.com/knowledgecenterpublic/livelink.exe/fetch/2000/348583/800332/800698/How_To_...

Please use plain text.
Developer
Raiden
Posts: 490
Registered: ‎07-16-2008
My Device: Not Specified

Re: Send Mail sample application

Tnx man' I got it'
Please use plain text.
Regular Visitor
javamdgouse
Posts: 1
Registered: ‎11-12-2010
My Device: BOLD 9000

Re: Send Mail sample application

[ Edited ]

Hello  Raiden,

 

Please send me "send email sample source Code" to me  <Personal Content Removed>

 

Thanks & Regards:

Mohammed Gouse

Blackberry Developer

Please use plain text.
Super Contributor
pg1181
Posts: 398
Registered: ‎01-12-2011
My Device: Q10
My Carrier: Fido

Re: Send Mail sample application

[ Edited ]

Don't mean to post over a solved question, but I've been having issues with that code:

 

The sample code seems to work fine "most" of the time over a 3G network. But I haven't gotten it to work via wifi. Even over 3G It works for me maybe 4 out of 5 times. Is there anywhere we can set the transport method for this?? I admit, I pretty much just copied and pasted this code with little research done on my part. Anyway to get this working consistently over any connection??

 

Thanks

Please use plain text.