Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
sblantipodi
Posts: 1,178
Registered: ‎02-19-2009
My Device: Not Specified

Signature tool from JDE 5.0 on a JDE 4.2 cod file.

Hi,

do you think that is better to use the latest signature tool (for example the one bundled with the JDE 5.0)

also with COD generated from JDE 4.2 for maximum compatibility?

 

If I sign a cod file with JDE 5.0, this will brick compatibility with previous OS also if the cod was build for example with JDE 4.2?

Thanks.

Please use plain text.
Developer
peter_strange
Posts: 19,603
Registered: ‎07-14-2008
My Device: Not Specified

Re: Signature tool from JDE 5.0 on a JDE 4.2 cod file.

I use the signing tool from 4.7 for all my signing, regardless of OS level it was built for.  So I think you will be fine using OS 5.0.  It will not brick any device. 

Please use plain text.
Developer
sblantipodi
Posts: 1,178
Registered: ‎02-19-2009
My Device: Not Specified

Re: Signature tool from JDE 5.0 on a JDE 4.2 cod file.

so why you use 4.7?

Please use plain text.
Developer
sblantipodi
Posts: 1,178
Registered: ‎02-19-2009
My Device: Not Specified

Re: Signature tool from JDE 5.0 on a JDE 4.2 cod file.

is there someone who can confirm that signature tool from JDE5 will not brick my cod?

I mean someone who is signing using JDE5?

Please use plain text.
Developer
peter_strange
Posts: 19,603
Registered: ‎07-14-2008
My Device: Not Specified

Re: Signature tool from JDE 5.0 on a JDE 4.2 cod file.

I use 4.7 because the last time I "rebuilt" my PC, it was the latest signing tool available. 

 

When signing multiple cods, one of the the earlier version (can't remember which one) would not tell you that later cods needing signing.  It seemed to stop checking the list if it hit one that was signed.  This annoyed me, so I swapped to the latest one I could. 

 

I can't 100% assure you that using 5.0 will not brick your device, but I would put money on it - my money.

 

If you are that concerned about it, then use on of the older signing jars.  The end result is the same. 

Please use plain text.
Developer
simon_hain
Posts: 16,113
Registered: ‎07-29-2008
My Device: Z10 LE, Z30, Passport
My Carrier: O2 Germany

Re: Signature tool from JDE 5.0 on a JDE 4.2 cod file.

we use the 5.0 signing tool since it was released.

you can still use the old signing as well, the newer work better on vista/7 i think.

----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
Please use plain text.
Developer
sblantipodi
Posts: 1,178
Registered: ‎02-19-2009
My Device: Not Specified

Re: Signature tool from JDE 5.0 on a JDE 4.2 cod file.

since there are only experimental comments on this topic I can't mark this thread as solved

but for now, thanks for your reply.

Please use plain text.
Developer
simon_hain
Posts: 16,113
Registered: ‎07-29-2008
My Device: Z10 LE, Z30, Passport
My Carrier: O2 Germany

Re: Signature tool from JDE 5.0 on a JDE 4.2 cod file.

you are aware of the fact that this is a user to user forum?

if you want statements from RIM you can try devsupport@rim.com or purchase support.

----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
Please use plain text.