Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
New Contributor
Posts: 9
Registered: ‎05-02-2010
My Device: Curve 8900

Simulator Problems

Hi everyone,

 

I am trying this out for the first time, so I apologize in advance if this info is available elsewhere. I looked but didn't find anything that solved my problem.

 

After some trial and error I have been able to get then BB Eclipse Plugin and JDE working (or so I think). I can create a BB project now and run it. My basic app fires the Simulator, but the simulator never works..all the items in the menu are available, but the main pane is empty.

when I move the mouse I see coordinates being written on the bottom bar..but I see nothing on the screen.

Sometimes a device appears in the simulator, but it's screen is always blank and clicking buttons on the BB does nothing.
I changed from the Storm simulator to the Bold 9700 and then the 8900. No luck with any.

Help, please!

Thanks!1869iA1649B225951F12C

Developer
Posts: 20
Registered: ‎02-15-2009
My Device: Not Specified

Re: Simulator Problems

Your app may be starting in the simulator bootup sequence, preventing it from actually fully starting up.

 

Try deleting any breakpoints in your app. Also try running the simulator without your app.

 

Another thing to try is to prevent the app from loading on start-up. In the application descriptor turn the General Information->Auto-run on startup option off. Also in your Run Configuration under Simulator->General make sure the "Launch app or URL on startup" field is cleared.

 

Your first order of business is to get the simulator running and see the OS. Good luck!

 

 

New Contributor
Posts: 9
Registered: ‎05-02-2010
My Device: Curve 8900

Re: Simulator Problems

Thanks for your response rxan. I tried but nothing worked. I decided to delete the Eclipse folder, uninstall everything and install the jde using the installer again, and allowing it to put Eclipse on my pc instead of installing (which is basically just unzipping Eclipse to a folder) Eclipse manually first. That worked right out of the box. I recommend that to everyone..it's easier.