Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
New Developer
thebity
Posts: 2
Registered: ‎10-20-2009
My Device: Not Specified

Simulator browserField onmousemove events not firing.

Hi,
I'm running the verison 5.0.0.252 of the 9500 Simulator. I have a mostly javascript based app that relies on the onmouseup, onmousedown, and (most relevantly) onmousemove events firing. To be specific, I have certain divs that are meant to scroll when a user drags within them (lists with overflow: hidden), but the onmousemove event is not firing.

I was initially having trouble with the scaling of the application, and thought that was the problem, but resolved them with the following BrowserFieldConfig options:

browserConfig.setProperty(

BrowserFieldConfig.USER_SCALABLE, Boolean.FALSE);
browserConfig.setProperty(BrowserFieldConfig.INITIAL_SCALE, new Float(1.0));

Question #1: With the previous options set, and the application filling 100% of the viewable window, clicking and moving the mouse should not make the entire window move. Is there some sort of config option that needs to be set so this does not happen?

Also, based on the documentation provided here (link below), I thought that I could get onmousemove to fire by using NAVIGATION_MODE_NONE, but the pointer continued to show up on the screen. I also tried NAVIGATION_MODE_POINTER with the expectation that it would behave like the "cursor" mode that's possible to get to from the actual Browser application.

http://www.blackberry.com/developers/docs/5.0.0api/net/rim/device/api/browser/field2/BrowserFieldCon...

Question #2: Are there any additional config options that need to be set in order to make onmousemove events fire? Based on my description, are NAVIGATION_MODE_NONE and NAVIGATION_MODE_POINTER behaving as expected?

Thanks for any help you can provide.
Please use plain text.
New Contributor
ericjbb
Posts: 6
Registered: ‎03-23-2010
My Device: SmartPhone
My Carrier: Verizon

Re: Simulator browserField onmousemove events not firing.

Did you ever get this resolved?

 

I am having the same problem.

 

 

Please use plain text.