Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Contributor
raphaelharboun
Posts: 33
Registered: ‎08-19-2010
My Device: Not Specified

Starting app on simulator cause Error module secure API

Hello everybody,

 

since a few days i have a strange problem with eclipse + simulator + bb 5.0

 

When the simulator closed and i launched my app for the first time everything works great, i can close the app and return to it and it works perfectly.

 

Now if i change a single thing in my code and re-run the app with the simulator open, the app crash on start with an exception and the "error module <> ...Secure API" which seems strange to me cause i though signing an app is only required when it's running on the device.

 

So the actual solution is to clean the project, package it and sign it , and then run it on the simulator which is still open, it asks me to give clearance to the app and then launch it normally...

 

It's very obscure to me...

 

thanks for your help

Please use plain text.
Developer
jprofitt
Posts: 604
Registered: ‎12-27-2010
My Device: Not Specified

Re: Starting app on simulator cause Error module secure API

Haven't found an actual solution to this myself, but I've noticed that if you add some try/catches around the code that is throwing the exception and allow the program to actually launch, you can just click Debug again (while the app itself is running, not just the simulator) and it will work without having to go through quite as many steps. At least this has worked for me.

Please use plain text.
Developer
vivart
Posts: 147
Registered: ‎08-27-2010
My Device: 9800
My Carrier: airtel

Re: Starting app on simulator cause Error module secure API

go to simulator properties-> general tab ->uncheck the "enable device security"

Please use plain text.
Contributor
raphaelharboun
Posts: 33
Registered: ‎08-19-2010
My Device: Not Specified

Re: Starting app on simulator cause Error module secure API

i made some research before writing this thread,

and i sould have said that yes i already verified that the enable securitu options was unchecked.

 

i will try the try/catch method,

 

thanks

 

 

Please use plain text.
Administrator
MSohm
Posts: 14,434
Registered: ‎07-09-2008
My Device: BlackBerry Z30, BlackBerry PlayBook
My Carrier: Bell

Re: Starting app on simulator cause Error module secure API

This is a known issue with some of the first 5.0 BlackBerry smartphone simulators that supported the hot swap feature (update the application without closing the simulator).  The work around is to close and re-open the simulator.

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
Please use plain text.