Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
sblantipodi
Posts: 1,178
Registered: ‎02-19-2009
My Device: Not Specified

Storm, software is not compatible...

Hi all,

today I received this msg from a customer:

"I try do download this software from suggested website for my Blackberry Storm. Message is popping out that this software in not compatible with my Storm."

 

As far as I know this software works perfectly on storm, what kind of error is this?
Have you got some idea?

 

Thanks.

Please use plain text.
Developer
RexDoug
Posts: 4,764
Registered: ‎07-21-2008
My Device: Not Specified

Re: Storm, software is not compatible...

What JDE level was the software compiled on?

 

What OS level is on the device?

 

 

Please use plain text.
Developer
rcmaniac25
Posts: 1,804
Registered: ‎04-28-2009
My Device: Z10 (STL100-4)-10.2.1.3253, Z10 (STL100-3)-10.3.1.634 Dev OS, Z30 (STA100-5)-10.3.1.634 Dev OS, Passport (SQW100-1)-10.3.0.1154, PlayBook (16GB)-2.1.0.1917
My Carrier: Verizon

Re: Storm, software is not compatible...

I have a feeling his customer is using OS 5.0. I have had a few applications that were for 4.7 and when I tried to load it I got a message saying it wasn't compatible even if RIM wrote it themselves.

 

I had made a post saying that I kept getting that message when I tried to load BB Wallet and it was supposed to just be able to just install it. The only way I was able to install it was when an update came out for it. If you have any bug fixes you might want to push out a new version and see if that works.

---Spends time in #blackberrydev on freenode (IRC)----
Three simple rules:
1. Please use the search bar before making new posts.
2. "Like" posts that you find helpful.
3. If a solution has been found for your post, mark it as solved.
--I code too much. Well, too bad.
Please use plain text.
Developer
RexDoug
Posts: 4,764
Registered: ‎07-21-2008
My Device: Not Specified

Re: Storm, software is not compatible...

yeah - this is the reason I asked.

 

We started having sporadic issues with devices running 5.0.0.xxx. Compiling the same 4.7 code under 5.0 made the issue go away.

 

 

Please use plain text.
Developer
sblantipodi
Posts: 1,178
Registered: ‎02-19-2009
My Device: Not Specified

Re: Storm, software is not compatible...

Hi, I compiled my software using JDE4.2 for maximum compatibility

this problem means that I need to develop two versions of my software,

one compiled with JDE4.2 and one compiled with JDE5.

 

This is absolutely terrible, is there a way to solve this problem?

How can I do with app store when I put in only one build for all phones?

 

Please help.

Please use plain text.
Administrator
MSohm
Posts: 14,528
Registered: ‎07-09-2008
My Device: BlackBerry Z30, BlackBerry PlayBook
My Carrier: Bell

Re: Storm, software is not compatible...

[ Edited ]

Are you specifying specific versions in your ALX file?  If so this error could be triggered if the ALX file excludes version 5.0.

 

Please report this issue to betadevsupport@rim.com including a copy of your application or a sample application that triggers this error.

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
Please use plain text.
Developer
RexDoug
Posts: 4,764
Registered: ‎07-21-2008
My Device: Not Specified

Re: Storm, software is not compatible...

Why is this still betadevsupport, Mark?

 

If I'm not mistaken, 5.0.3xx is out on at least three carriers in N.A. right now - probably more in EMEA.

 

Rogers, Verizon, and AT&T in N.A.

 

 

 

Please use plain text.
Administrator
MSohm
Posts: 14,528
Registered: ‎07-09-2008
My Device: BlackBerry Z30, BlackBerry PlayBook
My Carrier: Bell

Re: Storm, software is not compatible...

The 5.0 tools themselves are still in beta.

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
Please use plain text.
Developer
RexDoug
Posts: 4,764
Registered: ‎07-21-2008
My Device: Not Specified

Re: Storm, software is not compatible...

OK - but why do we still have a beta dev environment for an OS that is already in the wild?

 

:smileyhappy:

 

Please use plain text.
Developer
dpreussler
Posts: 212
Registered: ‎07-18-2008
My Device: Storm 9550

Re: Storm, software is not compatible...

that's a **bleep** good question. We are having the 1st customer 5.0 reports but can not get official simulators for reproduction  :smileysad:

If your problem was solved, please mark answer as "Accepted solution"
If your want to thank, click the "kudo" symbol
___________
visit me: http://mobilejavadevelopment.blogspot.com/
visit the Berlin BlackBerry Developer Group: http://berlinblackberrydevelopers.blogspot.com/
Please use plain text.