Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
New Contributor
amrsawy
Posts: 8
Registered: ‎03-17-2010
My Device: bold 9000
My Carrier: vodafone

Strange issue regarding direct tcp

Hello all,

 

i'm developing an application that connects to the internet using direct tcp

it works just fine on bolds and curves with OS 5.0

but when i tried to test it on OS 4.6 on curve 8520, it won't work. giving me a tunnel failed exception.

knowing that it works just fine on the same network using the same apn settings on other phones.

i even downloaded the network diagnostics tool and it couldn't connect through the direct tcp.

the device uses BIS connection so i don't think it's an IT policy or some administrator rule.

 

so any suggestions?

Please use plain text.
Developer
peter_strange
Posts: 19,601
Registered: ‎07-14-2008
My Device: Not Specified

Re: Strange issue regarding direct tcp

You did develop this app using 4.6 or earlier?

Please use plain text.
New Contributor
amrsawy
Posts: 8
Registered: ‎03-17-2010
My Device: bold 9000
My Carrier: vodafone

Re: Strange issue regarding direct tcp

i'm running it against api 4.6.0

and i'm testing it on curve 8520 also with os 4.6

i tried to trace the phone logs

it gave me something similar to

 

E net.rim.tcp - TNLf 0

a net.rim.tunnel - pdp2 2

a net.rim.tunnel - STnc - 00000000

a net.rim.tunnel - Open - Mobinilweb

a net.rim.tcp - open

 

mobinilweb is my apn, it works for other phones (using OS 5.0)

i still can't figure out why does it fail

Please use plain text.
New Contributor
amrsawy
Posts: 8
Registered: ‎03-17-2010
My Device: bold 9000
My Carrier: vodafone

Re: Strange issue regarding direct tcp

also i've traced Opera mini on the same device, it appears to open a connection using different transport or something as the logs show:

i net.rim.gme - RXst

i net.rim.mdp - RXst

 

but i'm not sure, is that a BIS connection?

Please use plain text.
New Contributor
amrsawy
Posts: 8
Registered: ‎03-17-2010
My Device: bold 9000
My Carrier: vodafone

Re: Strange issue regarding direct tcp

ok, now i have a more rigid problem description:

the apn settings won't connect on an edge nework, as i've tested it on a 9000 bold, made the network 2g only and it gave me the same tunnel error, so is that a network operator problem or am i missing something?

Please use plain text.
Developer
peter_strange
Posts: 19,601
Registered: ‎07-14-2008
My Device: Not Specified

Re: Strange issue regarding direct tcp

I wonder if you have an issue like this:

 

http://supportforums.blackberry.com/t5/Java-Development/Vodafone-UK-Direct-TCP/m-p/463081#M92387

 

So the device si trying for WAP despite the fact you have specified directTCP?

Please use plain text.