Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
Posts: 171
Registered: ‎08-20-2008
My Device: Not Specified

Suppress prompts after application install

Hi All,

 

Is there any way of suppressing the series of prompts and restarts the users received when deploying a custom Java application via the BES. I have created an Application Policy which has everything set to Allowed but still the users gets prompted to restart due to permission changes (not to much of a problem) and then when opening the app for the first time gets a prompt if they would like to add it as a trusted application, quite a big problem as someone is bound to select No. The users also gets another prompt asking if they wish to allow an external connection when connecting to an internal webservice. If anyone has any pointers on suppressing of these prompts please could you let me know. Cheers

BlackBerry Development Advisor
Posts: 15,070
Registered: ‎07-09-2008
My Device: BlackBerry Passport
My Carrier: Bell

Re: Suppress prompts after application install

The following link explains why a restart may be required.

 

What Is - The reason a reset is required when upgrading an application
Article Number: DB-00602

http://www.blackberry.com/knowledgecenterpublic/livelink.exe/fetch/2000/348583/800332/800620/What_Is...

 

The allow application to be trusted prompt shouldn't appear if the application has sufficient permissions set via an application control policy on the BlackBerry Enterprise Server.  However, our development team is aware of an issue that can cause prompt to incorrectly appear after an application has been pushed out from a BlackBerry Enterprise Server.  This should be fixed in a future release.

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
Developer
Posts: 171
Registered: ‎08-20-2008
My Device: Not Specified

Re: Suppress prompts after application install

Thanks for this, you have answered many of my questions in one. Does the issue with the prompts lie on the device or the BES do you know? Do you have an ETA on a fix, promise not to hold you to it but a rough estimate would be great :smileyhappy:

BlackBerry Development Advisor
Posts: 15,070
Registered: ‎07-09-2008
My Device: BlackBerry Passport
My Carrier: Bell

Re: Suppress prompts after application install

The issue lies within the BlackBerry handheld software, not the BlackBerry Enterprise Server.  The fix has gone into the following versions of BlackBerry handheld software: 4.5.0.111+, 4.6.0.197+ and 4.7.0.77+.

 

You can contact your carrier to see when/if they plan on releases new versions.

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
New Developer
Posts: 16
Registered: ‎12-18-2008
My Device: Not Specified

Re: Suppress prompts after application install

Hi,

 

We are facing a strange issue.

 

While upgrading an application, it does not prompt a reset but it deleted the previous version and did not install the newer one.

 

Application details:
Size : around 900KB
Number of sibling cod file: 29
Phone Model : 8320 Curve

BES version : 4.1.6

We have pushed application with version 1.0.26 successfully. We have been able to upgrade it with 1.0.27, 1.0.28 and 1.0.29. When we try upgrade it to 1.0.30, it removes the previous version (1.0.29) and does not install 1.0.30. And at the BES side it shows "Install Required".

 

While upgrading to 1.0.30, it shows some activity happening on BB phone (downloadng, N/W access etc). After some time, it removes the icon of the installed version and on the BES status it shows - Install Required.

 


We have confirmed that there is no issue in the package (1.0.30)- by pushing the same application from other BES (4.1.7) to a BB 8100 pearl successfully

Please help us solve the issue.

 

Best Regards,

Team Deltecs

www.deltecs.com