Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Contributor
carldea
Posts: 29
Registered: ‎02-14-2010
My Device: BlackBerry Curve 8530
My Carrier: Verizon Wireless
Accepted Solution

Unable to get BlackBerry Curve 8530 Simulator to show up in Eclipse run config -> device

 

 

 

 

To all those Eclipse fans...

 

 

I have installed the BlackBerry Curve 8530 Simulator which can be run inside the BlackBerry JDE, but unable to have it show up as one of the options under device for the Eclipse IDE. The simulators that show up in Eclipse in run configuration are 9000, 9550, 9700. I just like being in the Eclipse IDE.

 

 

 

Thanks... any help would be appreciated.

 

 

 

-Carl


BlackBerry Curve 8530 OS version 5.0.0.734
Please use plain text.
Developer
JCarty
Posts: 1,055
Registered: ‎01-25-2009
My Device: BlackBerry Bold 9650/BlackBerry Torch 9800

Re: Unable to get BlackBerry Curve 8530 Simulator to show up in Eclipse run config -> device

Which Eclipse plugin are you running? 1.0 or 1.1?

 

You may have to select a JDE pack that the 8530 simulator runs on, in order to get it to show up in the Eclipse plugin.

Jerome Carty - Follow jcarty on Twitter@jcarty | #webworks-dev / #BlackberryDev on irc.freenode.net | My Apps
Click "Accept as Solution" if post solved your original issue.. Give like/thumbs up if you feel post is helpful
Please use plain text.
Contributor
carldea
Posts: 29
Registered: ‎02-14-2010
My Device: BlackBerry Curve 8530
My Carrier: Verizon Wireless

Re: Unable to get BlackBerry Curve 8530 Simulator to show up in Eclipse run config -> device

JCarty,


 

 

Could you provide me the link to get the right download(s)?

I've tried the BlackBerry_JDE_PluginFull_1.1.1.200911111641-15.exe. with no success. It compiles and runs things fine, but doesn't show the 8530 simulator. The JDE plugin asked which eclipse directory ,so I chose it and installed with no change. Is it because I have Galileo Version: 3.5.1? I even downloaded the simulator. (BlackBerry_Simulators_5.0.0.337_8530-Verizon.exe). The BB JDE will launch it correctly. 

 

Thanks for your help

 

Carl

BlackBerry Curve 8530 OS version 5.0.0.734
Please use plain text.
Developer
JCarty
Posts: 1,055
Registered: ‎01-25-2009
My Device: BlackBerry Bold 9650/BlackBerry Torch 9800

Re: Unable to get BlackBerry Curve 8530 Simulator to show up in Eclipse run config -> device

I just tried to install it and had the same issue has you. You may want to report this in the Developer Issue Tracker.

 

Please see the sticky on top of the Java Development forum on how to do this. For now, I suggest coding for the 9700 which runs 5.0 too and go from there if you need.

Jerome Carty - Follow jcarty on Twitter@jcarty | #webworks-dev / #BlackberryDev on irc.freenode.net | My Apps
Click "Accept as Solution" if post solved your original issue.. Give like/thumbs up if you feel post is helpful
Please use plain text.
Contributor
carldea
Posts: 29
Registered: ‎02-14-2010
My Device: BlackBerry Curve 8530
My Carrier: Verizon Wireless

Re: Unable to get BlackBerry Curve 8530 Simulator to show up in Eclipse run config -> device

Jerome, Thanks for responding so quickly. I am liking the blackberry community. I plan to file this bug. I hope there is a search feature to see if it has already has been filed or not. Either way I will take your advice and use the 9700 for now. Another thing I could do is use the 8530 simulator and load the cod file but I may not have incremental debugging. Anyone know is the Zeemote will support the 8530 curve? Thanks again! Carl
BlackBerry Curve 8530 OS version 5.0.0.734
Please use plain text.
New Developer
rentepatrick
Posts: 16
Registered: ‎02-03-2010
My Device: Curve 5430
My Carrier: Developer

Re: Unable to get BlackBerry Curve 8530 Simulator to show up in Eclipse run config -> device

Hi!

 

I have the same problem. :smileysad:

Did you solve it?

 

Best regards

Please use plain text.
Contributor
carldea
Posts: 29
Registered: ‎02-14-2010
My Device: BlackBerry Curve 8530
My Carrier: Verizon Wireless

Re: Unable to get BlackBerry Curve 8530 Simulator to show up in Eclipse run config -> device

Yes!

 

I did figure out the problem.

 

Please read my last entry in the bug database:

https://www.blackberry.com/jira/browse/JAVAAPI-904

 

1) download Eclipse Galileo example: eclipse-java-galileo-SR1-win32.zip
2) unzip anywhere. example c:\
3) follow these instructions to use the update site: http://na.blackberry.com/eng/developers/javaappdev/javaupdate.jsp
4) install BlackBerry_Simulators_5.0.0.337_8530-Verizon.exe (you may not need to)

 

 

I also, want to test it with the new simulator that I noticed at the download area!

BlackBerry_Simulators_5.0.0.508_8530-Verizon.exe

 

I hope this helps!

 

-Carl

BlackBerry Curve 8530 OS version 5.0.0.734
Please use plain text.
Developer
JCarty
Posts: 1,055
Registered: ‎01-25-2009
My Device: BlackBerry Bold 9650/BlackBerry Torch 9800

Re: Unable to get BlackBerry Curve 8530 Simulator to show up in Eclipse run config -> device

Great work Carl!

 

If this thread is solved, could you mark it so that other users who have the same problem can find the solution? You can click "Accept as Solution" next to your last post since that solved it.

 

Thanks.

Jerome Carty - Follow jcarty on Twitter@jcarty | #webworks-dev / #BlackberryDev on irc.freenode.net | My Apps
Click "Accept as Solution" if post solved your original issue.. Give like/thumbs up if you feel post is helpful
Please use plain text.
Contributor
carldea
Posts: 29
Registered: ‎02-14-2010
My Device: BlackBerry Curve 8530
My Carrier: Verizon Wireless

Re: Unable to get BlackBerry Curve 8530 Simulator to show up in Eclipse run config -> device

Jerome,

 

Thanks.. I appreciate your help. I love the development environment so far. The similator is up to date too. I don't know who else to thank RIM or Verizon.

Applications can take advantage of incremental debugging easily. And I don't have to kill the simulator and restart it. Its much faster too.

 

Here is a breakdown of all the software a person needs as of this date: 4/27/2010

Others can maybe update this thread when new OS and Pluggin updates are announced. Let the fun begin! Enjoy.

 

BlackBerry Java Plug-in
Version:  1.1.2.201003212304-12

BlackBerry Java SDK
Version:  5.0.0.25

 

Eclipse Platform
Version: 3.5.1.R35x_v20090910-9gEeG1_FthkNDSP2odXdThaOu9GFDPn83DGB7
Build id: M20090917-0800

 

BlackBerry® Device Simulators v5.0.0.508 (8530 Verizon)

 

java version "1.6.0_20"
Java(TM) SE Runtime Environment (build 1.6.0_20-b02)
Java HotSpot(TM) Client VM (build 16.3-b01, mixed mode, sharing)

 

C:\blackberrydev\eclipse\eclipse.exe -vmargs -Xmx512M

 

 

I will be planning on blogging about my BlackBerry development adventures soon.

 

carlfx.wordpress.com

 

thanks!

Carl

 

BlackBerry Curve 8530 OS version 5.0.0.734
Please use plain text.