Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
New Developer
susmita
Posts: 2
Registered: ‎12-05-2009
My Device: Not Specified

Unable to run my App on Blackberry Bold 9700 (ATT)

I have this situation:

 

  • I am using Eclipse, with BB 4.7.0 component pack
  • I have got all the code signing keys
  • My application works fine on Blackberry Bold 9700 Simulator ( Generic version V 5.0.0.400)
  • I  loaded my app using Desktop Manager.

 

But when I try to run this application to my Blackberry Bold 9700 (ATT) . ( I did the code-signing etc...)  I get an error:

 

Error Starting MyApp: Module MyApp attempts to access a secure API.

 

I am using net.rim.device.api.crypto.MD5Digest

 

 

When I do 'about' on the device, it gives following info:

v5.0.0.405 (Platform 5.1.0.112)

 

 

Now, I have no idea why this is happening. Please help.

 

Please use plain text.
New Developer
ricos
Posts: 48
Registered: ‎06-08-2009
My Device: Bold 9000

Re: Unable to run my App on Blackberry Bold 9700 (ATT)

Which signing keys did you use to sign your code?

You should sign your codes  with RCC.

Please use plain text.
Developer
GlenBirkbeck
Posts: 54
Registered: ‎10-23-2008
My Device: Not Specified

Re: Unable to run my App on Blackberry Bold 9700 (ATT)

Did you use the file signer utility or did you use the the Blackberry -> Request Signatures option in Eclipse. I had similar problems with the standalone utility (it seemed to only do one of the three required signatures), but doing it from within Eclipse works fine.

Please use plain text.
Developer
Posts: 1,474
Registered: ‎04-14-2009
My Device: Not Specified

Re: Unable to run my App on Blackberry Bold 9700 (ATT)

[ Edited ]

As, ricos said, you may need to have your application signed with RIM's RCC key. To find out what signature is missing, clear the Event Log, cold-reboot the device (pull the battery), then obtain the Event Log, and post it here. During the power up phase, when signatures of all modules are verified, the verifier will log any missing signatures for your module.

Please use plain text.
Developer
simon_hain
Posts: 15,999
Registered: ‎07-29-2008
My Device: Z10 LE
My Carrier: O2 Germany

Re: Unable to run my App on Blackberry Bold 9700 (ATT)

i agree, the error is related to missing code signing. maybe you issued a new build and forgot to sign it or something similar. check your cod-file again maybe.

----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
Please use plain text.
New Contributor
smilebb
Posts: 5
Registered: ‎02-19-2010
My Device: NA
My Carrier: NA

Re: Unable to run my App on Blackberry Bold 9700 (ATT)

Hi,

 

My problem is somehow similar.

 

I am using JDE 4.7 have also signed my code and deployed  the cod file on server.

 

When I download it through browser on the simulatir, It works fine.

 

But when I try to download it on real blackberry device it gets downloaded , I am able to run it, the first page of the application gets opened but when I click on the Submit button on the login page  it doesn't go to the next page. It's workin fine on simulator 9700.

 

Can anybody help in this.

 

Thanks in advance.

 

Please use plain text.
Developer
simon_hain
Posts: 15,999
Registered: ‎07-29-2008
My Device: Z10 LE
My Carrier: O2 Germany

Re: Unable to run my App on Blackberry Bold 9700 (ATT)

welcome to the developer forums. please open a new thread for your problem.

----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
Please use plain text.
Developer
Blanc
Posts: 638
Registered: ‎07-02-2009
My Device: Not Specified

Re: Unable to run my App on Blackberry Bold 9700 (ATT)

Same exactly as the O.P my app is also not working in Bold AT&T 9700 device. The same cod file is working on Storm2 Verizon. Both the devices are OS 5.0 only.

Thanks and Regards,
PraveenGoparaju.
Please use plain text.
New Contributor
smilebb
Posts: 5
Registered: ‎02-19-2010
My Device: NA
My Carrier: NA

Re: Unable to run my App on Blackberry Bold 9700 (ATT)

Ok,I replied to this post coz my problem is somehow similar.

Please use plain text.