Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
theappspod
Posts: 122
Registered: ‎11-12-2010
My Device: Dev Alpha

Unable to see images created in app

Hi 

 

As some of you know (Peter) I have an app that creates an image and stores it in the Picture Library on the device. Now this has been tested on my BB device and several simulators and everything works fine.

 

However, today I had an email saying that they couldnt see the image in the picture library. and instead of seeing a thumbnail of the image they saw the icon representing an image as shown below:

 

s12_09_19__14_27_28.jpg

 

When they select the image to view they get a message saying "Unable to display file".  This is an Italian phone so my first though was the path I had coded was wrong so I got them to set their device to English - same problem. So I thought I would get them to hook their BB to their PC and see if they could see it there - they couldn't.

 

Anyone have any other suggestions?

 

 

Please use plain text.
Developer
theappspod
Posts: 122
Registered: ‎11-12-2010
My Device: Dev Alpha

Re: Unable to see images created in app

Just to add that I created an image on my BB and emailed it to them, they could open that fine.

 

Also their device is a 9360 on OS 7.1 if that makes a difference.  And I did download the 9360 simulator with OS 7.1 and it worked.

Please use plain text.
Developer
simon_hain
Posts: 16,207
Registered: ‎07-29-2008
My Device: Z10 LE, Z30, Passport

Re: Unable to see images created in app

i would suggest to test the other way around as well, let them send you a picture created on their device and check if you can display it.
maybe you can analyze the differences.
----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
Please use plain text.
Developer
theappspod
Posts: 122
Registered: ‎11-12-2010
My Device: Dev Alpha

Re: Unable to see images created in app

I will ask but im pretty sure they cannot see any files there to email.

 

As an update, she has tried to delete these from her BB but says shes unable to do so.  A bit more googling suggested taking the battery out, waiting 10 seconds and putting it back but this hasnt helped.

Please use plain text.
Developer
simon_hain
Posts: 16,207
Registered: ‎07-29-2008
My Device: Z10 LE, Z30, Passport

Re: Unable to see images created in app

if she accesses the filesystem folder using usb, are there any files at all?
----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
Please use plain text.
Developer
theappspod
Posts: 122
Registered: ‎11-12-2010
My Device: Dev Alpha

Re: Unable to see images created in app

ok, she hs reset again and its kind of working.

 

If she creates images whilst the device is in English then switches back to Italian she cant see the images she created whilst it was in English and vice versa.  This suggests that the path to the picture library changes with the language. Currently I am using "file:///store/home/user/pictures/filename.png"

Please use plain text.
Developer
simon_hain
Posts: 16,207
Registered: ‎07-29-2008
My Device: Z10 LE, Z30, Passport

Re: Unable to see images created in app

wow, that would be a strange implementation by rim!
----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
Please use plain text.