Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
Posts: 22
Registered: ‎06-11-2009
My Device: Bold 9700

Unable to sign after upgrade

[ Edited ]

Do I need to get my code signing keys reissued? I updated to the new version (which is a huge improvment over the last), but now I am unable to sign my code. I tried importing keys, but it gives me an error about private key.

 

Thanks,

Joel

BlackBerry Development Advisor
Posts: 137
Registered: ‎01-19-2010
My Device: BlackBerry Z10

Re: Unable to sign after upgrade

[ Edited ]

Hi Joel.  Can you please provide some more information, ideally a screenshot, of the error you encounter when you import your keys?  Also, is this moving from the 1.0 version or the 1.1 beta?

 

Thanks!

Ken Wallis - Senior Product Manager, WebWorks and Android Runtime
@ken_wallis
Developer
Posts: 22
Registered: ‎06-11-2009
My Device: Bold 9700

Re: Unable to sign after upgrade

[ Edited ]

Hello,


I'm not sure what I had before, the folder was net.rim.ejde.componentpack5.0.0_5.0.0.14

I think I imported them from the wrong location, I'm not entirely sure where I'm supposed to be importing them from. I read somewhere that it should be in the

net.rim.ejde.componentpack5.0.0_5.0.0.14/components/bin

folder but nothing was in there.

I'm just going to email devsupport and get them reissued.

 

Thanks,

Joel

BlackBerry Development Advisor
Posts: 137
Registered: ‎01-19-2010
My Device: BlackBerry Z10

Re: Unable to sign after upgrade

[ Edited ]

Can you try taking a look in the directory:

plugins\net.rim.ejde, there should be a sigTool directory there?  If you point to that directory in the Import keys wizard, what happens?

Ken Wallis - Senior Product Manager, WebWorks and Android Runtime
@ken_wallis
Developer
Posts: 83
Registered: ‎02-19-2010
My Device: Not Specified

Re: Unable to sign after upgrade

Hello,

 

I had the same problem with signing my app, but after import keys I can do that! But know eclipse told me that I successfully signed my app and I got many mails from the websigner, that my app is successfully signed but when I load this app on my BlackBerry he told me the following error:

 

Error starting %APP%: Module %APP% attempts to access a secure API.

 

What is the Problem? I thought I signed my app!

 

Best regards

Maja

Developer
Posts: 83
Registered: ‎02-19-2010
My Device: Not Specified

Re: Unable to sign after upgrade

Ok I don't know why, but know it act!