Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
New Developer
r_debashis
Posts: 9
Registered: ‎09-01-2008
My Device: Not Specified

What is the minimum version of Blackberry required for socket push?

Hi,

 

Want to develop a push application that uses socket push. I am getting a ConnectionNotFoundException for Blackberry version 4.1.x.

What is the minimum version of Blackberry software (the value you get when you click About in Options) required for this application?

Is this the same if I want to register a push on http?

 

Thanks,

Debashis

Developer
Posts: 5,339
Registered: ‎09-20-2008
My Device: ***
My Carrier: ***

Re: What is the minimum version of Blackberry required for socket push?

What classes do you need to implement this functionality?

 

Check for RIM API 4.7.0 javadocs for these classes.

 

And note about information like: since RIM API 4.2.0  in the class description.

 

RIM API version and device software version are the same.

New Developer
r_debashis
Posts: 9
Registered: ‎09-01-2008
My Device: Not Specified

Re: What is the minimum version of Blackberry required for socket push?

Hi,

 

I am not using any RIM specific API. I simply using javax.micro...io.PushRegistry. That too, I am doing a static registration of the url socket://:5555.

 

Thanks,

Debashis 

 

Developer
Posts: 5,339
Registered: ‎09-20-2008
My Device: ***
My Carrier: ***

Re: What is the minimum version of Blackberry required for socket push?

In this case it should work with device software 4.0 and newer. (4.1, 4.2, 4.3, 4.5, etc)

 

Maybe it will work with older device software but I did not check older RIM API JavaDocs.

 

If these classes are present in older RIM API, then it should work in older device software.