Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
Posts: 24
Registered: ‎09-04-2008
My Device: Not Specified
Accepted Solution

When trying to debug, it takes long time and JDE hang.

Dear Sir/madam,

 

I use the Blackberry JDE 4.1, 4.2, 4.3, 4.5 and 4.6. At first, I can debug with device and simulator. Now when I even try to debug the built-in samples application , the simulator hang and it show debugging attachment... and it never go on.

So, I close the simulator and try to close the JDE. The JDE never response after trying to debug. I cannot click any thing and cannot close the JDE. I can only close the JDE from Task Manager. It is occuring in all JDE.

 

I tried to uninstall the JDE and installed again. But after reinstalling, the problem is still occuring.

 

Please kindly tell me any possible solution! or Please tell me why it is happening like this!

 

Thanks you,

With regards,

Sweet Sweet

Developer
Posts: 53
Registered: ‎12-11-2008
My Device: Not Specified

Re: When trying to debug, it takes long time and JDE hang.

Try to reinstall Java.
Developer
Posts: 24
Registered: ‎09-04-2008
My Device: Not Specified

Re: When trying to debug, it takes long time and JDE hang.

Hi Thanks you for your reply

 

I tried to uninstall the java and JDE . And reinstalled everything again.

 

But it is still hang and cannot start up.

 

Please cann you tell me for other way!

 

Thanks you 

With regards

Sweet Sweet

 

Developer
Posts: 146
Registered: ‎11-05-2008
My Device: Not Specified

Re: When trying to debug, it takes long time and JDE hang.

just for question,have you set the autorun option for your application while debugging it?
Developer
Posts: 19,631
Registered: ‎07-14-2008
My Device: Not Specified

Re: When trying to debug, it takes long time and JDE hang.

I use and debug in all the JDE versions that you are indicating you have a problem with, so it is certainly possible.  You indicate that it has suddenly stopped working.  The obvious question to ask is, what changed between it working and not?

 

But I wondering if there is a simpler solution.  When my simulators come up, I get a dialog box on windows which points out that my debug files don't match.  With this dialog box up, the Simulator is 'attaching' with the hourglass is going round, while the JDE appears hung.  If this looks like your situation, then look for a Dialog box you need to respond to on your Windows system.  Minimize everything, it might be hidden.

Developer
Posts: 24
Registered: ‎09-04-2008
My Device: Not Specified

Re: When trying to debug, it takes long time and JDE hang.

Hi thanks you for your reply!

 

I haven't set the auto run to any project.

 

But now, I used the erase method from JDE. I erased all the file system, non-volitile memory and removalble memory.

 

So, it is working well now.

 

Thanks you ,

With regards,

Developer
Posts: 24
Registered: ‎09-04-2008
My Device: Not Specified

Re: When trying to debug, it takes long time and JDE hang.

Hi thanks you for your reply!

 

Before that problem occured, the dialog box is came up. But when the problem occour, any dialog box is came up.

 

Now, I solved this problem with erase all the file system, non volitile memory and removable memory.

 

Thanks you,

With regards,