Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
Juergen
Posts: 22
Registered: ‎08-22-2008
My Device: Bold
Accepted Solution

Which is the correct JDE Version for cross Bios Version development?

Hello, 

I’m developing an application that is targeted to run on all BBs running Firmware 4.3 or higher.

What is the best JDE to use?

Should we always use the newest JDE (4.6) or is it better to stay with the older JDE 4.3 ?

 

Regards Juergen Haakert

 

Developer
Developer
gtj
Posts: 319
Registered: ‎07-20-2008
My Device: Not Specified

Re: Which is the correct JDE Version for cross Bios Version development?

Anything developed under 4.3 will run on 4.6 but not everthing developed with 4.6 will run on 4.3.  So, I'd recommend sticking with 4.3.  I stick with 4.2.1 because that's the lowest common platform.

 

 

Developer
simon_hain
Posts: 16,282
Registered: ‎07-29-2008
My Device: Z10 LE, Z30, Passport

Re: Which is the correct JDE Version for cross Bios Version development?

i would also suggest 4.2.1
below you have the problem that the navigation-methods are not in the API, if you choose 4.3 you cover less devices. not all customers want to upgrade, for whatever reasons.
----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
Developer
Juergen
Posts: 22
Registered: ‎08-22-2008
My Device: Bold

Re: Which is the correct JDE Version for cross Bios Version development?

My Personal preference is Version 4.3.

This is the oldest Version supporting the APIs I need.

I just wanted to here some other voices.