Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
Posts: 1,178
Registered: ‎02-19-2009
My Device: Not Specified

Re: Windows 7 and BlackBerry JDE

is there a solution for people running Blackberry simulator without ecplise?

New Contributor
Posts: 8
Registered: ‎11-04-2009
My Device: Not Specified

Re: Windows 7 and BlackBerry JDE

Thanks Marc, Your solution work for me on Windows 7, i installed on C:\RIM folder and its working.

 

Thanks

Suresh Nariya.

 

Developer
Posts: 56
Registered: ‎01-11-2009
My Device: Not Specified

Re: Windows 7 and BlackBerry JDE

Hi All:

 

Just came across this thread.

I have WIndows 7 on a 64 bit machine. However, all installs that I did were 32 bit versions.

 

I installed latest version of Java JDK.

 

I installed JDE4.7, JDE4.5 and JDE4.2 in a non-default directory (not Program Files) as stated previously in this thread. I had to change PATH enviroment variable to point to the correct place for javac.

 

I got new code signing for the Windows 7 machine.

 

I have succeeded in the following:  I can compile, build, code sign, and execute on 9530 simulator (so far as I've tested).

 

I am seeing two problems:

1.  The app.cod file does not contain all modules that it should (should be around 800K and it is around 125K). Nonetheless, I can execute my app on the 9530 simulator.

2. When I execute javaloader to download to a real device, I get an error.

 

If anyone has seen these problems, I would appreciate some light.

 

Olaf

 

Highlighted
New Developer
New Developer
Posts: 151
Registered: ‎01-05-2010
My Device: dev alpha c (bb10)
My Carrier: www.rzr.online.fr

Re: Windows 7 and BlackBerry JDE

Hi,

I can install SDK and run eclipse

but the simulator BlackBerry 9800

fail to refresh drawing

Is this a related issue ?


winver: windows 7 Edition Familiale Premium 6.1 (numero 7600)

 

Developer
Posts: 653
Registered: ‎02-03-2010
My Device: Z10 LE
My Carrier: Rogers

Re: Windows 7 and BlackBerry JDE

For the simulator try and set the Graphics Acceleration to OFF under the View menu of simulator.


Steven Kader at JaredCo
   Follow me on Twitter    |     Mipixi.com :  Web App for Photo Sharing