Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
Posts: 121
Registered: ‎11-29-2008
My Device: Not Specified
Accepted Solution

apps works with Storm but gave CMM no sig 0x33 for BB 8830, 8330, 8310

Hi all,

 

I am at a lost as to why my apps works perfectly on Storm but not on any other devices (8830,8330, 8310). It generates an event message CMM no sign 0x33 everytime my apps try to open an HTTP connection. I am using the latest JDE 4.7, could this be my problem? Should I down grade my JDE to 4.6?

 

Thank you for your help.

Developer
Posts: 19,618
Registered: ‎07-14-2008
My Device: Not Specified

Re: apps works with Storm but gave CMM no sig 0x33 for BB 8830, 8330, 8310

BlackBerry software is forward but not backward compatible.  So for devices like the 8310 which typically run OS 4.3, you should develop on JDE 4.3.  Your JDE 4.7 code should NOT be run on this device - in fact I have seen devices bricked by the installation of an application that was developed on a later level JDE than the OS on the device.

 

The general rule is that you should develop on the JDE that matches the lowest level of OS you intend to install on. 

 

There has been loads of discussion in this forum on ways to develop using the same code base but for different platforms, so that you can take advantage of the facilities of the later platforms.  Please look around for this, if you would like to research it.

 

The CMM message is a red herring - review the following Thread:

http://supportforums.blackberry.com/rim/board/message?board.id=java_dev&message.id=3658

Developer
Posts: 121
Registered: ‎11-29-2008
My Device: Not Specified

Re: apps works with Storm but gave CMM no sig 0x33 for BB 8830, 8330, 8310

Thanks a million Peter. I am learning something new everyday.