Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Contributor
Posts: 48
Registered: ‎07-20-2010
My Device: Not Specified
My Carrier: developer

browser issue !

[ Edited ]

hi.. i have created an application which passes video url in browser when user selected.. when the url get passed in browser, it shows dialog box tat do you want to open, save or cancel .. land then it is playing in default player.. i dont want to display such open, save messages.. is there any way to get rid of this message..????

Developer
Posts: 132
Registered: ‎05-07-2009
My Device: Curve
My Carrier: Vodafone

Re: browser issue !

i dont understand, if you are passing video URL to browser.... it will do its default behaviour....  what exactly do you want to happen... when you pass video URL to browser....

 

you can write your own browser implementation.... if you want.... the code is given in the samples that come with blackberry JDE installer....

Sameer Joshi
Blackberry developer.
Contributor
Posts: 48
Registered: ‎07-20-2010
My Device: Not Specified
My Carrier: developer

Re: browser issue !

sameer.. wat i want is i need to parse a video http url and i need to play it.. i ve tried for video player construction.. i have failed in it..so i ve decided to play using browser.. i m jus asking is there any way to play video without asking open , save etc..in player

Developer
Posts: 132
Registered: ‎05-07-2009
My Device: Curve
My Carrier: Vodafone

Re: browser issue !

What you basically want to do is HTTP stream your video URL in your application ....

 

Use the player thing...

 

Streaming Media

 

Use the above link... it has everything including the code attached at the bottom.... i feel this will make your life easy....

 

 

Sameer Joshi
Blackberry developer.
Highlighted
Contributor
Posts: 48
Registered: ‎07-20-2010
My Device: Not Specified
My Carrier: developer

Re: browser issue !

@sameer...

 i have tried this already sameer.. i m using JDE 5..actually if we are passing a direct url in this player means it plays the video in the in the emulator.. but i m parsing the video url and storing it in a string and i m passing the string as the url.. then its not working.. even i debugged it.. the value gets passed but not playing.. more over if v pass a direct url also it not working in the device.. i m using blackberry bold 9000.. so only i ve tried using browser.. this is my problem.. can u give me any suggestion ????