Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
New Developer
Posts: 2
Registered: ‎12-20-2008
My Device: Not Specified

camerademo doesnt save on storm

I've tested the camerademo included in the 4.6 jde with the bold simulator. It works fine. Then i've tested the same application on the storm simulator. It seems to work. But when i want to display the saved photo with the mediabrowser, it can't be displayed. I see a thumbnail of the photo but when I open the file nothing is displayed. I have the same problem on the real storm device. When I connect the storm device via USB to the computer the Blackberry Manager says the image is corrupt.

 

Can anyonereproduce this problem?

Developer
Posts: 3,951
Registered: ‎07-15-2008
My Device: Not Specified

Re: camerademo doesnt save on storm

What is the approximate size of the image, on which resolution you capturing the image.

 

Tnx.


Use Search. "Accept Solution" If the problem is resolved.
New Developer
Posts: 2
Registered: ‎12-20-2008
My Device: Not Specified

Re: camerademo doesnt save on storm

On the simulator i've tested it with 3 different images. Each one with another size. I've tested bmp and jpg. In the application i can choose different resolutions. I've tested them all.
BlackBerry Development Advisor
Posts: 834
Registered: ‎07-15-2008
My Device: Passport
My Carrier: Bell

Re: camerademo doesnt save on storm

Can you try changing the file extension to .jpg instead of .bmp? The demo encodes the image in a JPG format, but saves it as a .bmp file which confuses the media application. Can you also provide your Handheld Code version from Options->About?

 

Thanks

Tim

Tim Windsor
Open Source Technical Lead
New Developer
Posts: 5
Registered: ‎01-21-2009
My Device: Not Specified

Re: camerademo doesnt save on storm

Hello, not sure if this is related but my storm is not liking the 4.7 examples. I have a brand new storm and tried to get the 4.7 updates for my eclipse set up it first asks me to connect, which I use as my login creditials. Things seem to log in ok but then I get the error below that it is expecting a zip file and instead is getting a jar file. Any ideas? Strange...

 

moving on, reason I'm posting here: I set up the 4.7 BB JDE and tried out 5 or 6 samples until I tried out the camera sample CameraDemo. I was able to compile and run fine but when I hit the Take Photo button nothing happens. weird right? let me know if you have seen this. 

BlackBerry Development Advisor
Posts: 15,021
Registered: ‎07-09-2008
My Device: BlackBerry Passport

Re: camerademo doesnt save on storm

Regarding the BlackBerry JDE Plug-in for Eclipse download issue.  This was caused by a problem with the update site, which has been resolved.  The issue of multiple login prompts does still remain (it currently prompts you for each file you download).

 

For the second issue, what BlackBerry handheld software version are you testing on?  You can find this under Options, About on the BlackBerry Smartphone.

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
New Developer
Posts: 5
Registered: ‎01-21-2009
My Device: Not Specified

Re: camerademo doesnt save on storm

The blackberry information reads as follows:

 

- BlackBerry 9530 v4.7.0.75 (Platform 4.0.0.94)

- Cryto Kernel v3.8.5.51

- Branding version: 1.0.105.100

- ME Mediaa Version: 1.1

 

Anything else you need? Have you tried this sample camera demo on an actual device? The emu works fine...just the device itself isn't trigerring the event "createImageScreen( _videoControl.getSnapshot( encoding ) );" inside the "fieldChanged(Field field, int context)"

 

Let me know any ideas you have or things to try. Thanks again!

 

Jason

New Developer
Posts: 5
Registered: ‎01-21-2009
My Device: Not Specified

Re: camerademo doesnt save on storm

I'm still having this problem with the camera. Has anyone tried to put the camera demo on the storm and see if it is maybe just my handset's broken?
BlackBerry Development Advisor
Posts: 15,021
Registered: ‎07-09-2008
My Device: BlackBerry Passport

Re: camerademo doesnt save on storm

I ran the camerademo using the same version and had no issues.  What exception are you receiving?  If it is a ControlledAccessException please ensure that the application has been granted the Recording permission under Interactions in the application permissions (Options, Advanced Options, Applications, select camerademo and choose Edit Permissions from the menu.
Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
New Developer
Posts: 5
Registered: ‎01-21-2009
My Device: Not Specified

Re: camerademo doesnt save on storm

Wow that did the trick. I just re-read the example, JDE API and all the examples i could find although I must have missed one. Does it say this is needed in the docs somewhere?

 

Thanks again, working great!