Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
syedshakeel2004
Posts: 29
Registered: ‎12-28-2009
My Device: Not Specified
Accepted Solution

.cod file not generated

Hello everyone,

 

this may be a silly question. I have eclipse 3.4 and blackberry JDE 5.0 and 4.5 component. I have activated 5.0 component plugin for eclipse. I had made one application. It created .cod file. After that i made one change in the code then after builded that app. the expected output didn't come.So i deleted the .cod from workspace and from eclipse/plugins/5.0/component/simulator for that. Now it is not creating the .cod file. Even though i have made new project and new workspace also and blackberry project is also activated but still .cod file is not created. but on 4.5 JDE component it is creating.

 

can somebody help me out that what is the problem for 5.0 component.

 

with thanx and regards shakeel

Please use plain text.
Developer
ibarrera
Posts: 588
Registered: ‎05-29-2009
My Device: 9100

Re: .cod file not generated

Do you get any error in the console when you "Build Active Blackberry Configuration" into project menu?

Please use plain text.
Developer
syedshakeel2004
Posts: 29
Registered: ‎12-28-2009
My Device: Not Specified

Re: .cod file not generated

hi,

 

 

thanx  for reply. while building the active project there is not ay error is displayed.

 

with thanx and regards

shakeel

Please use plain text.
Developer
ibarrera
Posts: 588
Registered: ‎05-29-2009
My Device: 9100

Re: .cod file not generated

I would try to debug the application setting a breakpoint in the main method to see if it's really launching the application or giving to you back some errors.

Please use plain text.
Developer
syedshakeel2004
Posts: 29
Registered: ‎12-28-2009
My Device: Not Specified

Re: .cod file not generated

hi ibarrera,

 

                    thanx for replying. While debugging and putting breakpoint in main method it is not giving any error. but there is not the same application to be debug on the simulator. So nothing is happennig and we can't move forward without the application. but it is launching the simulator succesfully.

 

with thanx and reagrds

shakeel

Please use plain text.
Developer
pankajpareek
Posts: 68
Registered: ‎09-29-2009
My Device: Not Specified

Re: .cod file not generated

Hello Dear Shakeel

                                     Do one thing .

1. Create one another project  and give name like demo..ok

2.Now all the content copy from last project and paste into demo.

3. now check activate for blackberry and run it.

4. you can get .cod file in workspace folder .

 

Best of luck.

Pankaj Pareek.

Please use plain text.
Developer
pankajpareek
Posts: 68
Registered: ‎09-29-2009
My Device: Not Specified

Re: .cod file not generated

Have you updated 5.0 JDE plugin in eclipse..May be this is cause of problem...

 

 

Go in Eclipse IDE:-

help->sofwrae update->Install 5.0 JDE.zip and install then again restart your eclipse.

 

This is must.

 

Please use plain text.
Developer
syedshakeel2004
Posts: 29
Registered: ‎12-28-2009
My Device: Not Specified

Re: .cod file not generated

Hi to all,

                 thanx pankaj sir,

 

this is i have tried i have created one new workspace and new project and also reinstalled the 5.0 JDE plugin. still i am not able to get .cod file for any project for blackberry JDE 5.o plugin.

 

any other suggestions.

 

with thanx and regards

shakeel

Please use plain text.
Developer
ibarrera
Posts: 588
Registered: ‎05-29-2009
My Device: 9100

Re: .cod file not generated

When you "Build Active Blackberry Configuration" into project menu.. do you get something like this? or do you get some kind of error or warning?

Executing rapc for the project ProjectBB at Wed Dec 30 08:02:38 CET 2009.
C:\eclipse\plugins\net.rim.eide.componentpack........................................................................................

...........................................................................................
rapc executed for the project ProjectBB

Please use plain text.
Developer
syedshakeel2004
Posts: 29
Registered: ‎12-28-2009
My Device: Not Specified

Re: .cod file not generated

hi ibarrera,

 

                 thanx for reply.

when i "Build Active Blackberry Configuration" into project menu..then i am getting .....

 

Executing rapc for the project DataServ at Wed Dec 30 17:35:59 GMT+05:30 2009.

 

 

 

But when try to run the application then there is not any .cod file generated and i have only .jdp and .rapc file of my app.

It is strange that i have again reinstalled the eclipse, JDE plugin and created new  workspace. and on JDE 4.5 any app is working fine but for JDE 5.0 it is not generating anything.

 

 

with thanx and regards

shakeel

 

Please use plain text.