Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
New Developer
cmveas
Posts: 16
Registered: ‎07-28-2009
My Device: Not Specified

could not make Open GL ES example work on emulator

Hello all Im tryin to start learning open GL with Blackberry. Im trying to start with this example. So  I create a new project in my eclipse and create the class OpenGLTest and copied the example content. But Sadly the emulator does not show me anything when I execute the example.

If you have any ideas (like code errors or if there is an emulator that does not display OpenGL stuffs) I dont have any experience with Open Gl so I cant say if the code must work but since is an official example Im putting my trust in it.

Here are the data of the tools Im using:

Eclipse with 1.1 plugin Beta

Emulator 5.0.0.334

If you need more information pls ask

Thanks in advance

Claudio

Please use plain text.
Developer
rcmaniac25
Posts: 1,804
Registered: ‎04-28-2009
My Device: Z10 (STL100-4)-10.2.1.2174, Z10 (STL100-3)-10.3.0.700 Dev OS, Z30 (STA100-5)-10.3.0.700 Dev OS, PlayBook (16GB)-2.1.0.1917
My Carrier: Verizon

Re: could not make Open GL ES example work on emulator

What simulator are you using? Only ones that support OpenGL is 8530, 9520, 9550, and 9650 support OpenGL so if you aren't running on one of those then it won't work.

---Spends time in #blackberrydev on freenode (IRC)----
Three simple rules:
1. Please use the search bar before making new posts.
2. "Like" posts that you find helpful.
3. If a solution has been found for your post, mark it as solved.
--I code too much. Well, too bad.
Please use plain text.
New Developer
cmveas
Posts: 16
Registered: ‎07-28-2009
My Device: Not Specified

Re: could not make Open GL ES example work on emulator

Thanks for the reply!! I was using a 9700 emulator but now I tried with 9550 and still I get this blank screen. Anyway Im going to try to download and use another simulator and I ll let you know how It went. If anything else comes to you pls let me know.

Claudio

Please use plain text.
Developer
rcmaniac25
Posts: 1,804
Registered: ‎04-28-2009
My Device: Z10 (STL100-4)-10.2.1.2174, Z10 (STL100-3)-10.3.0.700 Dev OS, Z30 (STA100-5)-10.3.0.700 Dev OS, PlayBook (16GB)-2.1.0.1917
My Carrier: Verizon

Re: could not make Open GL ES example work on emulator

OK, the 9700 does not support OpenGL, if you call GLUtils.isSupported() you will find out if it is supported or not.

---Spends time in #blackberrydev on freenode (IRC)----
Three simple rules:
1. Please use the search bar before making new posts.
2. "Like" posts that you find helpful.
3. If a solution has been found for your post, mark it as solved.
--I code too much. Well, too bad.
Please use plain text.
New Contributor
reverse
Posts: 2
Registered: ‎08-30-2010
My Device: 8700

Re: could not make Open GL ES example work on emulator

But what about 9550, and 9650? I'm trying to do the same on 9650 simulator now - no luck at all!

(I've debugged, traced it, all seems to be okay, the bitmap for a texture is loaded, the size matches, no errors after glTexImage2D, but I see only black screen)

Please use plain text.
Developer
rcmaniac25
Posts: 1,804
Registered: ‎04-28-2009
My Device: Z10 (STL100-4)-10.2.1.2174, Z10 (STL100-3)-10.3.0.700 Dev OS, Z30 (STA100-5)-10.3.0.700 Dev OS, PlayBook (16GB)-2.1.0.1917
My Carrier: Verizon

Re: could not make Open GL ES example work on emulator

If you aren't getting any errors then it might be something in your code.

---Spends time in #blackberrydev on freenode (IRC)----
Three simple rules:
1. Please use the search bar before making new posts.
2. "Like" posts that you find helpful.
3. If a solution has been found for your post, mark it as solved.
--I code too much. Well, too bad.
Please use plain text.
New Contributor
reverse
Posts: 2
Registered: ‎08-30-2010
My Device: 8700

Re: could not make Open GL ES example work on emulator

You mean in code written by RIM in samples and examples? Why am I not surprised?

Please use plain text.
Developer
rcmaniac25
Posts: 1,804
Registered: ‎04-28-2009
My Device: Z10 (STL100-4)-10.2.1.2174, Z10 (STL100-3)-10.3.0.700 Dev OS, Z30 (STA100-5)-10.3.0.700 Dev OS, PlayBook (16GB)-2.1.0.1917
My Carrier: Verizon

Re: could not make Open GL ES example work on emulator

No, I did a straight copy paste and it works for me or RIMs code. What code do you have?

 

The only area that their might be issues with is the glDrawArrays function because it doesn't support "sections" right now.

 

So where it might say "draw one side, now the next, now the next..." you need to have it all draw at the same time for it to work. I posted this on Issue Tracker but they couldn't reproduce it, I'm going to repost it and update it so that it has a better chance of occuring.

---Spends time in #blackberrydev on freenode (IRC)----
Three simple rules:
1. Please use the search bar before making new posts.
2. "Like" posts that you find helpful.
3. If a solution has been found for your post, mark it as solved.
--I code too much. Well, too bad.
Please use plain text.