Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
aryan777
Posts: 76
Registered: ‎02-21-2009
My Device: Not Specified
Accepted Solution

eclipse plugin issue

[ Edited ]

Hello all,

 

I have been facing some issue with the plugin for a while and I am unable to resolve it.

 

The problem is any program I run in the simulator runs in the startup. To eliminate complexities, I have created a new project and just have the HelloWorld class from the HelloWorld demo as the source. Still it is running on startup.

 

I have double checked the Blackberry_App_Description.xml file. AutoRun on startup is unchekced and there is no entry in the 'Alternate Entry Points' either.

 

Following are some details:

Eclipse- 3.5

Blackberry Java SDK - 5.0

eclipse plugin- 1.1.2

Blackberry simulator-9550

 

Thanks in advance.

 

 

Regular Contributor
devin
Posts: 51
Registered: ‎05-11-2010
My Device: 8900

Re: eclipse plugin issue

I am having a simular issue with the new eclipse plugin.  I have been developing on the old plugin and decided to upgrage with the new eclipse client and plugin but my app is running differently in the new version.

 

  I have a background app that runs on start up.  In the old plugin it works fine, however when I run in on the new plugin the first screen displays as soon as the simulator starts.  And I get exceptions when I try to close the screen.  The first screen is supposed to be displayed in the activate method, this is never called in the startup of the old simulator (or on the actual blackberry device).

 

Anyone know a way around this?

 

Thanks.

Regular Contributor
devin
Posts: 51
Registered: ‎05-11-2010
My Device: 8900

Re: eclipse plugin issue

I figured out my issue with the app always starting up.  Found it on another thread on here. 

 

If you go under the Debug Configurations there is a simulator tab.  In there is a text box with the title

Launch App or URL on startup.

 

Make sure this is blank.  Hope that helps, this has been driving me crazy.