Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
New Developer
learningbb
Posts: 45
Registered: ‎06-05-2009
My Device: Not Specified

https and camera related issues

Hi All Forum members,

 

I have two issues, which I need to reply back to client asap.

 

1.  I  am developing a third party application,  for which I need to make https://<www.xyz.abc>,  but the blackberry for some reason does not allow https calls, however if I make http calls, then I am able to hit the site and get the data.

I contacted the customer care guys here, they told me that https is not supported inherently on blackberry.

 

Is this info rite? because the client has written all the api calls using https.

how do I tell client about this https issue?

 

2.  I have a feature which lets user take the photo from the blackberry device camera, i have noticed that the camera app auto saves the photo to  a predefined location, my requirement is to take this name and predefined location, where this photo is saved back to a screen, where it is being displayed and also provide the user with option to upload this

newly taken pic to a server.

 

is it possible to get the name and the location the photo has been saved once the camera app exits automatically and return it to my screen for furthering processing?

 

Thanks and rgds.

 

 

Developer
rihan007
Posts: 455
Registered: ‎01-14-2009
My Device: Apple iPhone 3GS 16GB

Re: https and camera related issues

1. Whats the issue you are getting when connecting to https websites? i am able to connect to https without any issues.

New Developer
learningbb
Posts: 45
Registered: ‎06-05-2009
My Device: Not Specified

Re: https and camera related issues

Hi,

 

On debugging on the device, i found that

 

httpconnections http = (httpconnection) Connector.open(<url>);

 

This  line throws  error, it goes to the catch block

 

and the stacktrace is as follows:

 

IOException
Bad DNS Address
net_rim_cldc-12
TcpClientConnection
<init>
0xA4EB
net_rim_cldc-12
Protocol
openConnection
0x6C3D
net_rim_cldc-5
RimConnectionFactory
openPrim
0x8B6C
net_rim_cldc-14
RIMConnector
<private>
0x9187
net_rim_cldc-14
RIMConnector
open
0x8EB8
net_rim_cldc-2
Connector
open
0x1E17
net_rim_os-4
Protocol
openPrim
0x23A7
net_rim_cldc-14
RIMConnector
<private>
0x9187
net_rim_cldc-14
RIMConnector
open
0x8EB8
net_rim_cldc-2
Connector
open
0x1E17
net_rim_os-2
Protocol
<private>
0x9CE1
net_rim_os-2
Protocol
openPrim
0x9B1C
net_rim_cldc-14
RIMConnector
<private>
0x9187
net_rim_cldc-14
RIMConnector
open
0x8EB8
net_rim_cldc-2
Connector
open
0x1E17
net_rim_os-2
HttpConnection

 

I am not able to understand this, i dont get this error for http calls for the same API.

 

Thanks and Rgds.

 

 

 

Developer
rihan007
Posts: 455
Registered: ‎01-14-2009
My Device: Apple iPhone 3GS 16GB

Re: https and camera related issues

 

streamConnection = (StreamConnection)Connector.open(url);

httpsConn=(HttpsConnection)streamConnection;

 

Try this and let me know