Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
New Contributor
Tom74
Posts: 8
Registered: ‎12-04-2012
My Device: Curve 9300
My Carrier: Telecom

installing apps on device

hi everybody, i'm new in blackberry programming... i've installed jde 6.0; a lot of apps exemples come with it.. When I try toimport these samples projects into eclipse (3.7.2) I see that all of them comes with some error so that I can't package or signing or loading into device because an error about NullException comes out when trying one of these operations. If I import samples project that comes with jde 7.1 then everything goes well... Whats the problem ? Eclips 3.7.2 only support jde 7.1 ? How can I import older projects without having troubles ? thanks Tom
Please use plain text.
Developer
kamal_nigam
Posts: 434
Registered: ‎07-23-2012
My Device: Blackberry 10
My Carrier: Orange

Re: installing apps on device

Problem might be other. I am using same version of eclipse and not getting any issue.

Try with only one sample and see are u facing same issue ?

Thanks
-------------------------------------------------------------------------------------
Press the Accept as solution Button when u got the Solution
Press Kudo to say thank to developer.
-------------------------------------------------------------------------------------.
Please use plain text.
New Contributor
Tom74
Posts: 8
Registered: ‎12-04-2012
My Device: Curve 9300
My Carrier: Telecom

Re: installing apps on device

I've also tryied with only one jde 6.0 sample but I've got same issue.

My problem is that I have to use Eclipse for signing code and sending app to device otherwise I would have used JDE 6 Environment . But with it I cannot sign code !

 

going back to Eclipse this is what I do:

 

1) File-->Import-->BlackBerry-->import blackBerry samples

2) in JRE section I've to selct JDE 6.0 if I want to import samples that came with it (default is JRE 7.1); so I search other installed JREs and I pick JDE 6.0

3) select only GpsDemo and Press Finish

 

The projects is imported with a little red symbol meaning error and I cannot package, signing or loading on device !

 

Really don't know what else to do ! I wasted a whole day for this issue ..:No:

 

Thanks

Please use plain text.
Developer
kamal_nigam
Posts: 434
Registered: ‎07-23-2012
My Device: Blackberry 10
My Carrier: Orange

Re: installing apps on device

I did the same but not getting error. Ok go to problems view and check the message you are getting.

Try clean project as well

Thanks
-------------------------------------------------------------------------------------
Press the Accept as solution Button when u got the Solution
Press Kudo to say thank to developer.
-------------------------------------------------------------------------------------.
Please use plain text.
New Contributor
Tom74
Posts: 8
Registered: ‎12-04-2012
My Device: Curve 9300
My Carrier: Telecom

Re: installing apps on device

I've tried to clean up project...but same issue.

that's the message I've got when trying to package or loading to device

 

An internal error occurred during: "Packaging projects...".
java.lang.NullPointerException

 

please help

 

thanks

Please use plain text.
New Contributor
Tom74
Posts: 8
Registered: ‎12-04-2012
My Device: Curve 9300
My Carrier: Telecom

Re: installing apps on device

Ok I solved my problem....

I've loaded other jdr plugs in from bleckberry..

 

Now I have another issue....I can sign, package and send to device (BlackBerry Curve 9300 with Blackberry 6.0) but after installing app I click on it and nothing happens..

 

Can somebody explaining me why ?

 

Thanks

Please use plain text.