Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
New Contributor
Posts: 3
Registered: ‎02-18-2013
My Device: curve 8520
My Carrier: iusacell

my sample apps doesn´t works

Hi everybody, i´m working with a bb curve 8520 and a bold 9780 working with eclipse version Version: 3.7.2
Build id: M20120208-0800 blackberry sdk 7.1 

 

the problem with all the apps is for example

Error starting BluetoothSerialPortDemo: Class 'net.rim.device.api.command.CommandHandler' not found

 

could you help me please_?

New Contributor
Posts: 3
Registered: ‎02-18-2013
My Device: curve 8520
My Carrier: iusacell

Re: my sample apps doesn´t works

i forgot to mention that are signed

Developer
Posts: 4,764
Registered: ‎07-21-2008
My Device: Not Specified

Re: my sample apps doesn´t works

[ Edited ]

Are your devices running OS 7.1?

 

If not, you'll need to rebuild under the appropriate level. Your SDK level should be <= your target device OS level.

 

New Contributor
Posts: 3
Registered: ‎02-18-2013
My Device: curve 8520
My Carrier: iusacell

Re: my sample apps doesn´t works

yes but it doesn´t works

 

Highlighted
Developer
Posts: 19,631
Registered: ‎07-14-2008
My Device: Not Specified

Re: my sample apps doesn´t works

Note this comment:

"If not, you'll need to rebuild under the appropriate level. Your SDK level should be <= your target device OS level."

 

You are compiling for OS 7.1.  The 8520 does not OS 7.1, in fact AFAIK the highest OS it can run is OS 5.0.  So you need to download and install SDK 5.0 and use that for your development when you want to install on the 8520.

 

Instructions on this page:

http://developer.blackberry.com/java/download/

Look for "Installing additional BlackBerry SDK versions".