Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
New Developer
Posts: 28
Registered: ‎03-04-2009
My Device: Bold 9700

net_rim_crypto not found

Im trying to run my app on a 8520 simulator in Eclipse. When I click on the icon of my app I get an error saying: Module net_rim_crypto not found. My Java build path library is pointing to JDE6.0\lib. When I change that to 5.0 it works fine. Why would 6.0 give this error?

New Developer
Posts: 28
Registered: ‎03-04-2009
My Device: Bold 9700

Re: net_rim_crypto not found

Silly question. OS6 obv not meant to run on 8520 and is probably causing the error.

New Developer
Posts: 15
Registered: ‎08-29-2009
My Device: Not Specified

Re: net_rim_crypto not found

Hi CharlesZA

 

It is not really a silly question... if you are not using any OS6.0 APIs and compiling against JDE6.0, it should be fine, however, it seems that JDE6.0 is not backward compatible.

 

Regards,

Halaseh

New Contributor
Posts: 3
Registered: ‎12-24-2010
My Device: 9700

Re: net_rim_crypto not found

I have same problem: net_rim_crypto not found, but not same app.

when i want install Fancy CharCore 4.1.5, pop window show me this wrong....

 

I don't know why?

New Contributor
Posts: 3
Registered: ‎12-24-2010
My Device: 9700

Re: net_rim_crypto not found

Oh,,,, I install on hardware BB9700 OS 5.0.0.1014, not on the simulator

New Contributor
Posts: 6
Registered: ‎12-20-2009
My Device: 8520 Curve
My Carrier: Telenor

Re: net_rim_crypto not found

I have a blackberry 8520 with OS 5.0 and on running / installing certain applications i get net_rim_crypto not found, how to fix this ?