Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
jackofall
Posts: 120
Registered: ‎06-23-2009
My Device: Not Specified

'net.rim.device.api.ui.decor.Border' not found

hi,

I am using this "decor " api to develop the menu things but i am getting not found error when i deploy application on

Blackberry 8230.

Is there any way to update the software of the phone to use this api? 

Thanks & Regards

Behind me is infinite power,
Before me is Endless Possibility,
Around me is Boundless Opportunity,
Why should I fear!
Developer
paulhaenel
Posts: 220
Registered: ‎09-09-2008
My Device: Bold 9780

Re: 'net.rim.device.api.ui.decor.Border' not found

depending on what version of the OS is installed you can upgrade it.

 

have look at this thread :

 

http://www.blackberryforums.com/general-8300-series-discussion-curve/116212-what-latest-os-blackberr...

 

 

-----------

Follow me on twitter: twitter.com/paul.haenel

If your issue is resolved, please mark this thread as solved.

Set the "Solution" mark on the post which contains the answer to your question.
Developer
jackofall
Posts: 120
Registered: ‎06-23-2009
My Device: Not Specified

Re: 'net.rim.device.api.ui.decor.Border' not found

Thanks for your reply,

 

I have got
Package Version: 4.2.2

and i saw that there are some higher versions available e.g 


Package Version: 4.5.0.255

 

But my concern is to use decor package which came in JDE 4.6.

Anyone use this API , please let me know.

!.Should i upgrade my phone

2.After getting this 4.5 OS version, i would be able to use this decor API.

net.rim.device.api.ui.decor.*; 

 

Thanks & Regards

Behind me is infinite power,
Before me is Endless Possibility,
Around me is Boundless Opportunity,
Why should I fear!
Developer
bikas
Posts: 984
Registered: ‎02-10-2009
My Device: Not Specified

Re: 'net.rim.device.api.ui.decor.Border' not found

decor package came along JDE 4.6.0.

So you have to get 4.6 or greater OS version installed for using this api.

 

Regards

Bikas

Developer
Posts: 43
Registered: ‎09-28-2009
My Device: Not Specified

Re: 'net.rim.device.api.ui.decor.Border' not found

Hi jackofall,

 

In this post I explained the difference between pre 4.6 borders and post 4.6(including4.6) borders. Please go through the post again, and if you have any futher issues keep the questions in that thread and rather refrain from opening another one that deals with the same issue.

 

Hope this will help.

 

Regards

 

Andre

Developer
jackofall
Posts: 120
Registered: ‎06-23-2009
My Device: Not Specified

Re: 'net.rim.device.api.ui.decor.Border' not found

Thanks bikas,

This make sense, but i have two more questions.

 

1.os 4.6 is available and how can i get it down? 

2. Can i install it on 8320?

 

I am searching myself but if you have any clue , plese let me know!

Thanks & Regards

Behind me is infinite power,
Before me is Endless Possibility,
Around me is Boundless Opportunity,
Why should I fear!
Developer
jackofall
Posts: 120
Registered: ‎06-23-2009
My Device: Not Specified

Re: 'net.rim.device.api.ui.decor.Border' not found

Sorry andre_impi,

 

Your article was very helpful but this is a different issue,

 

I am facing some problems regarding deployment.

 

My bb 8320 gives me error not found.

It has OS 4.2.2, i found OS 4.5 

and i need 4.6 which i didn't find so far.

 

Thanks & Regards

Behind me is infinite power,
Before me is Endless Possibility,
Around me is Boundless Opportunity,
Why should I fear!
Developer
bikas
Posts: 984
Registered: ‎02-10-2009
My Device: Not Specified

Re: 'net.rim.device.api.ui.decor.Border' not found

AFAIK, 4.6 will not work on the 8320.

 

Check this post. You will get some information regarding OS upgrade.

http://forums.pinstack.com/f184/latest_official_curve_8320_os_-_apr_18_2009_a-92071/

 

Regards

Bikas

 

 

Developer
peter_strange
Posts: 19,612
Registered: ‎07-14-2008
My Device: Not Specified

Re: 'net.rim.device.api.ui.decor.Border' not found

Here is another useful link, that lists the latest known releases for each device.  The latest one for your device is 4.5.  

 

http://www.blackberryforums.com/rim-software/110673-useful-latest-os-all-models.html