Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
titakalpesh
Posts: 203
Registered: ‎07-30-2009
My Device: Bold(9780),Curve(8520)
My Carrier: Vodafone

opengl support in Blackberry?

Hello every one,

 

i tried to run the sample example of openGL given in JDE 6 in 9800 but it nit running perfectly get say that "_eglChooseConfig returned no valid configs" so please any body have any idea about this help me to do this.

 

Thanks In advanced

Tita

Please use plain text.
Developer
jonberry
Posts: 484
Registered: ‎07-17-2008
My Device: Not Specified

Re: opengl support in Blackberry?

I don't think the 9800 has open gl support.

Please use plain text.
Developer
rcmaniac25
Posts: 1,804
Registered: ‎04-28-2009
My Device: Z10 (STL100-4)-10.2.1.2174, Z10 (STL100-3)-10.3.0.700 Dev OS, Z30 (STA100-5)-10.3.0.700 Dev OS, PlayBook (16GB)-2.1.0.1917
My Carrier: Verizon

Re: opengl support in Blackberry?

No it does not. OpenGL is only avalible on CDMA BlackBerry's right now (and only specific ones at that), the 9800 is GSM.

---Spends time in #blackberrydev on freenode (IRC)----
Three simple rules:
1. Please use the search bar before making new posts.
2. "Like" posts that you find helpful.
3. If a solution has been found for your post, mark it as solved.
--I code too much. Well, too bad.
Please use plain text.
Developer
titakalpesh
Posts: 203
Registered: ‎07-30-2009
My Device: Bold(9780),Curve(8520)
My Carrier: Vodafone

Re: opengl support in Blackberry?

ok ,

But if i want to run that app which simulator i have to use would you please suggest me the proper device and mthod.

 

Thanks

Tita

Please use plain text.
Developer
rcmaniac25
Posts: 1,804
Registered: ‎04-28-2009
My Device: Z10 (STL100-4)-10.2.1.2174, Z10 (STL100-3)-10.3.0.700 Dev OS, Z30 (STA100-5)-10.3.0.700 Dev OS, PlayBook (16GB)-2.1.0.1917
My Carrier: Verizon

Re: opengl support in Blackberry?

9550, 8530, think there is three, can't think of last one. Make sure you use API 5.0 or higher (those have OpenGL ES apis).

---Spends time in #blackberrydev on freenode (IRC)----
Three simple rules:
1. Please use the search bar before making new posts.
2. "Like" posts that you find helpful.
3. If a solution has been found for your post, mark it as solved.
--I code too much. Well, too bad.
Please use plain text.
Contributor
billybaloop
Posts: 20
Registered: ‎11-15-2010
My Device: Not Specified

Re: opengl support in Blackberry?

As of now its 9550 9650 and 8530.

Please use plain text.
Contributor
billybaloop
Posts: 20
Registered: ‎11-15-2010
My Device: Not Specified

Re: opengl support in Blackberry?

Now I have a question, are these 3 the only ones that support OpenVG as well?

Please use plain text.
Developer
rcmaniac25
Posts: 1,804
Registered: ‎04-28-2009
My Device: Z10 (STL100-4)-10.2.1.2174, Z10 (STL100-3)-10.3.0.700 Dev OS, Z30 (STA100-5)-10.3.0.700 Dev OS, PlayBook (16GB)-2.1.0.1917
My Carrier: Verizon

Re: opengl support in Blackberry?

[ Edited ]

Didn't notice that article, thanks for bringing it up. If they support OpenGL and run OS 6.0 then they could support OpenVG. I say could because from what I can tell they require OpenGL must be OpenGL 1.1 in order for it to work.

 

Edit: MSohm just updated the article. I forgot the BlackBerry Style supports OpenGL 1.1 and OpenVG 1.1.

---Spends time in #blackberrydev on freenode (IRC)----
Three simple rules:
1. Please use the search bar before making new posts.
2. "Like" posts that you find helpful.
3. If a solution has been found for your post, mark it as solved.
--I code too much. Well, too bad.
Please use plain text.