Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
New Contributor
rolandw
Posts: 2
Registered: ‎03-23-2011
My Device: a
My Carrier: student

problem with the BlackBerry_App_Descriptor.xml in Eclipse Plug-In 1.3 "InvalidRegex"

[ Edited ]

Hi,

I'm working with the BlackBerry PlugIn 1.3.0 with Eclipse Helios on Win7 32bit.

when I build a BlackBerry Project I have this message:


InvalidRegex: Pattern value '([a-zA-Z_]{1,63}[\s-a-zA-Z_0-9.]{0,63}[;]?)*' is not a valid regular expression. The reported error was: ''-' is an invalid character range. Write '\-'.' at column '{2}'.    BlackBerry_App_Descriptor.xml       Unknown    XML Problem

 

Please, can anybody help me?

Please use plain text.
Developer
simon_hain
Posts: 15,956
Registered: ‎07-29-2008
My Device: Z10 LE
My Carrier: O2 Germany

Re: problem with the BlackBerry_App_Descriptor.xml in Eclipse Plug-In 1.3 "InvalidRegex"

welcome to the support forums.

 

maybe you took an invalid version number? it is only allowed in the a.b.c format with each letter representing a number of 1-3 digits.

 

otherwise check the xml file manually for the sign

----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
Please use plain text.
New Contributor
rolandw
Posts: 2
Registered: ‎03-23-2011
My Device: a
My Carrier: student

Re: problem with the BlackBerry_App_Descriptor.xml in Eclipse Plug-In 1.3 "InvalidRegex"

Thanks for your Answer,

I checked the XML File but there is no '-' .

That's the XML File:

 

<Properties ModelVersion="1.1.2">
  <General Title="TestApp" Version="1.0.0" Vendor="BlackBerryDeveloper" Description=""/>
  <Application Type="BlackBerry Application" MainMIDletName="" MainArgs="" HomeScreenPosition="4" StartupTier="7" IsSystemModule="false" IsAutostartup="false"/>
  <Resources hasTitleResource="false" TitleResourceBundleName="" TitleResourceBundleRelativePath="" TitleResourceBundleClassName="" TitleResourceBundleKey="" DescriptionId="">
    <Icons>
      <Icon CanonicalFileName="res\img\icon.png" IsFocus="false"/>
    </Icons>
  </Resources>
  <Compile OutputCompilerMessages="false" ConvertImages="true" CreateWarningForNoExportedRoutine="true" CompressResources="false" AliasList="">
    <PreprocessorDefines/>
  </Compile>
  <Packaging PreBuildStep="" PostBuildStep="" CleanStep="" OutputFileName="TestApp" OutputFolder="deliverables" GenerateALXFile="true">
    <AlxFiles/>
  </Packaging>
  <HiddenProperties>
    <ClassProtection/>
    <PackageProtection/>
  </HiddenProperties>
  <AlternateEntryPoints/>
</Properties>

 

The Version Number is 1.0.0

 

Any other Ideas?

Please use plain text.
Developer
Hithredin
Posts: 401
Registered: ‎06-03-2010
My Device: Z10 Red
My Carrier: Free

Re: problem with the BlackBerry_App_Descriptor.xml in Eclipse Plug-In 1.3 "InvalidRegex"

Is it the first time it happens on your eclipse?

 

You may also download the eclipse plugin 1.3.1

Please use plain text.
Developer
simon_hain
Posts: 15,956
Registered: ‎07-29-2008
My Device: Z10 LE
My Carrier: O2 Germany

Re: problem with the BlackBerry_App_Descriptor.xml in Eclipse Plug-In 1.3 "InvalidRegex"

i don't know a solution, then. maybe create a new project and add the files to it (you can just copy them over) solves the problem.

i still work with the 1.1 plugin as the 1.3 one had some issues for me.

----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
Please use plain text.
New Contributor
hmaass
Posts: 2
Registered: ‎03-17-2011
My Device: Torch 9800, Bold 9780, Bold 9000, Storm 9520, Curve 8310
My Carrier: T-Mobile

Re: problem with the BlackBerry_App_Descriptor.xml in Eclipse Plug-In 1.3 "InvalidRegex"

Make sure that the Eclipse Java Plug-in starts with the JDK, not a JRE.

 

Edit the eclipse.ini and add the "vm" parameter, which should point to a javaw.exe of a JDK installation.

 

---------------------<snip>

 

--launcher.defaultAction
openFile
-vm
C:\Programme\Java\jdk1.6.0_17\bin\javaw.exe
-vmargs
-Dosgi.framework.extensions=net.rim.ejde.preprocessing.hook
-Xms40m
-Xmx512M
-XX:MaxPermSize=512m

----------------------<snap>

 

Cheers,

 

Heiko

 

Please use plain text.
Contributor
DanielRaap
Posts: 21
Registered: ‎02-17-2011
My Device: Not Specified

Re: problem with the BlackBerry_App_Descriptor.xml in Eclipse Plug-In 1.3 "InvalidRegex"

Thanks for the tip. The vm parameter has not worked for me, but removing Java 7 removed that error (I had also other problems with Java 7, so I just got rid of it)

Please use plain text.
Visitor
cryo243
Posts: 1
Registered: ‎07-30-2011
My Device: 8520
My Carrier: Student

Re: problem with the BlackBerry_App_Descriptor.xml in Eclipse Plug-In 1.3 "InvalidRegex"

man I have exactly the same problem... please tell me what java sdk u used when u removed java 7 coz I have java 6update 27 it still giving me the same error... pls help

Please use plain text.
New Member
vkarmapolice
Posts: 1
Registered: ‎08-08-2011
My Device: Torch
My Carrier: AT&T

Re: problem with the BlackBerry_App_Descriptor.xml in Eclipse Plug-In 1.3 "InvalidRegex"

It works for me.

Please use plain text.
Contributor
Melad
Posts: 10
Registered: ‎07-18-2011
My Device: 8520
My Carrier: Mobinil

Re: problem with the BlackBerry_App_Descriptor.xml in Eclipse Plug-In 1.3 "InvalidRegex"

What is your project name ?

Do not use special characters in project names.

Please use plain text.