Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
anildeveloper
Posts: 33
Registered: ‎07-16-2008
My Device: Not Specified

receive email in ess simulator special hack

sending mails FROM the simulator works nearly always;

sending mails TO the simulator works not always; so I spent hours; then I read in some of the RIM-Guides, that I have to start the web-browser on the simulator for doing some initialization and it works; now every time I start the device-simulator I enter the blackberry-browser and try to open a web-page; the browser starts but the webpage doens't open because it is only connected to ESS; but the important thing you see in the console-window from your ESS

 

<Mon Sep 28 09:04:19 CEST 2009>: [29] :<DEBUG>:<LAYER = UDP, EVENT = Receiving, SIZE = 333, SOURCE = localhost:19780, DESTINATION = localhost>
<Mon Sep 28 09:04:19 CEST 2009>: [30] :<DEBUG>:<LAYER = UDP, EVENT = Sending, SIZE = 11, SOURCE = , DESTINATION = localhost:19780>

the web-request made a udp-connection to ESS and now it is correctly initialized and now sending mails TO the simulator works;

thanks to the rim-people who documented that in the simulator-guides;

anil

 

 

environment:

eclipse 3.4.1

bb eclipse-plugin 1.0.0.67

ess simulator net.rim.eide.componentpack4.5.0_4.5.0.16

device simulator (starting from bb eclipse) 8800 with firmware 4.5.0.44

operating system of my workstation: windows xp with latest patches

jdk: 1.6.0_16