Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
New Developer
bscan48
Posts: 4
Registered: ‎12-31-2008
My Device: Not Specified
Accepted Solution

trouble running HelloWorldDemo

I'm using 4.6.1 of the JDK.  I think that I have all the correct

software installed, and have my path set correctly, but when

I set the active project to HelloWorldDemo, build, and run

the simulator comes up, but the demo app is not in the applications

folder.

Please use plain text.
Developer
Posts: 5,339
Registered: ‎09-20-2008
My Device: ***
My Carrier: ***

Re: trouble running HelloWorldDemo

Check the "Downloads" folder.

 

It is there.

 

Happy new year :smileyhappy:

Please use plain text.
Developer
AntonioJSG
Posts: 35
Registered: ‎10-11-2008
My Device: Not Specified

Re: trouble running HelloWorldDemo

Try use the simulator's top menu /File/Load Java Program

 

Then browse to the directory where the .cod file is built, select it and click "Open".

 

I do this every time I build the application.  Be sure to close your application within the simulator before you reload it.

 

If you get bad behavour use /File/Reset.

 

 

 

Please use plain text.
Developer
mreed
Posts: 1,041
Registered: ‎07-16-2008
My Device: ಠ_ಠ

Re: trouble running HelloWorldDemo

If you build to the simulator directory then you wouldn't need to load it manually.
Please use plain text.
New Developer
bscan48
Posts: 4
Registered: ‎12-31-2008
My Device: Not Specified

Re: trouble running HelloWorldDemo

Yes, the HelloWorldDemo.cod is in the simulator forlder.  I have tried to

do file>load java program and that does not work either.

Please use plain text.
Developer
Posts: 5,339
Registered: ‎09-20-2008
My Device: ***
My Carrier: ***

Re: trouble running HelloWorldDemo

Have you checked "Downloads" folder on the simulator ?
Please use plain text.
Developer
Posts: 5,339
Registered: ‎09-20-2008
My Device: ***
My Carrier: ***

Re: trouble running HelloWorldDemo

Check this animated picture for instructions:

 

http://picasaweb.google.ru/tbilisoft/BlackberryForum#5286749232655663042

Please use plain text.
New Developer
bscan48
Posts: 4
Registered: ‎12-31-2008
My Device: Not Specified

Re: trouble running HelloWorldDemo

Ok, found the program in the downloads.  Thank you!

 

Please use plain text.
Developer
Posts: 5,339
Registered: ‎09-20-2008
My Device: ***
My Carrier: ***

Re: trouble running HelloWorldDemo

Please resolve the thread. Set "Solution" mark on the right side of the post which contain the answer.
Please use plain text.
Regular Contributor
ramroum1986
Posts: 94
Registered: ‎02-27-2010
My Device: rien
My Carrier: etudiant

Re: trouble running HelloWorldDemo

hello I have the same problem, the application does not find in downloading and file. COD does not exist
Please use plain text.