Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
New Developer
Posts: 4
Registered: ‎04-21-2009
My Device: Not Specified

unable to generate .cod file !!!!!!!!!

hi all...

 

i am facing  a very peculiar problem in my blackberry project.. i am unable to generate .cod file of my project... till yesterday , everything was working fine.. i was able to run my application on 8300 simulator.. today, i ran clean.bat file to remove all the unwanted applications from the simulator.. and since then i am not able to run my application as well.. i have tried resetting the classpath as well but that also does not seem to work... In the project folder there is not cod file as well as debug file...

 

now , i am out of options wondering what to do... if anyone can guide me out of this mess it will be higly appreciated....

 

thanks

Developer
Posts: 3,951
Registered: ‎07-15-2008
My Device: Not Specified

Re: unable to generate .cod file !!!!!!!!!

Is your application getting compiled and build?

Use Search. "Accept Solution" If the problem is resolved.
Developer
Posts: 5,339
Registered: ‎09-20-2008
My Device: ***
My Carrier: ***

Re: unable to generate .cod file !!!!!!!!!

What is going on with your application ?

 

Does JDE compile your application and launch the simulator ?

 

Can you find the app icon on simulator ?

 

Please describe the error as detailed as possible.

New Developer
Posts: 4
Registered: ‎04-21-2009
My Device: Not Specified

Re: unable to generate .cod file !!!!!!!!!

my application is not getting build..i think so.. becuase , In the project folder, i do not see any file that should be there like .cso, .cod , .jar, .jdp , .debug , .rapc     etc.. etc..

 

 

New Developer
Posts: 4
Registered: ‎04-21-2009
My Device: Not Specified

Re: unable to generate .cod file !!!!!!!!!

i am working on eclipse IDE... i think it is not compiling the application ... simulator is being launched but it does not show my applications icon... 

 

actually what happened was,.. during development yesterday, i noticed that whatever changes i am making in the code were not getting reflected in the application.. so i ran clean.bat file to reomve the application ... but now when i am compiling it again, there is no sign of my application on the simulator..  i deleted my .cod , .jar , .cso, .csl , .debug files from my project folder manually, thinking that they will be generated again when i will compile the code again and this is what usually it should happen.. but now what i see is that even these files are not getting generated ... so it's obvious from where will i get my application on the simulator...

 

i have checked all my evironment variables also including classpath and done a reset, but things do not seem to work...

 

i hope now i am able to explain that what is happening ... for any further clarifications , please revert back as soon as possible..

 

thx...

Developer
Posts: 5,339
Registered: ‎09-20-2008
My Device: ***
My Carrier: ***

Re: unable to generate .cod file !!!!!!!!!

If you are a newbie start with Java Development Environment.

 

I do not use Eclipse at all, because I have found this tool less convenient than Netbeans.