Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
footose
Posts: 300
Registered: ‎03-12-2009
My Device: Not Specified

using different JRE

I've recently installed the latest eclipse with the 5.0 BlackBerry JRE, but I would like to compile with the 4.6 JRE.

 

I have downloaded and installed the 4.6 Component pack and installed it, but the 4.6 JRE is not showing up in the Libraries porition of Eclipse.

 

it is only showing JRE sysetm library [Blackberry JRE 5.0.0] and if i goto "edit" it will also show "jre6".

 

How do I enable the JRE 4.6 component pack ?

 

Thanks

 

Please use plain text.
Developer
SamuelD
Posts: 166
Registered: ‎01-14-2009
My Device: Curve 8330

Re: using different JRE

[ Edited ]

Hello,

in the BuildPath, double click on JRE System Library. You should see a dropdown box with all installed components. You can look in Installed JRE... to see if you new component is correctly installed.

 

If you can't see the JRE, you cann take a look in you Eclipse install folder under Plugin/net.rim.ejde.componentpack4.6.0/components if there is a BlackBerry.ee file. You can manually add the component by selecting this file when doing Add in the Installed JRE window.

Thank you, have a nice day.

--
Samuel D.
Please use plain text.
Developer
footose
Posts: 300
Registered: ‎03-12-2009
My Device: Not Specified

Re: using different JRE

Hey Samuel, thanks for the response.

 

I should have been more specific - I have already tried the above and it's still not listed :smileysad:

 

 

Please use plain text.
Developer
footose
Posts: 300
Registered: ‎03-12-2009
My Device: Not Specified

Re: using different JRE

looks like im getting a bit further.. but not by much.

 

  Missing requirement: BlackBerry JDE Component Package 4.6.0 4.6.0.19 (net.rim.eide.componentpack4.6.0 4.6.0.19) requires 'bundle net.rim.eide 0.0.0' but it could not be found

 

 

Please use plain text.
Developer
SamuelD
Posts: 166
Registered: ‎01-14-2009
My Device: Curve 8330

Re: using different JRE

Hello,

have you took a look at this post:

 

http://supportforums.blackberry.com/t5/Java-Development/New-eclipse-plugin-and-Blackberry-SDK-4-5-0/...

Thank you, have a nice day.

--
Samuel D.
Please use plain text.
Developer
rajeshkparmar
Posts: 104
Registered: ‎08-03-2010
My Device: Blackberry Z10
My Carrier: Idea

Re: using different JRE

Hii,

 

You have done with manually setting of the BlackBerry.ee file by following Steps..

 

Step 1. Extract the component pack to plug ins folder.

 

Step 2. Copy and paste the BlackBerry.ee file to your 4.5or 4.6 Component pack's components Folder .

 

Step 3. Edit BlackBerry.ee file with appropriate with 4.6 text like..-Dee.name=BlackBerry JRE 5.0.0 to -Dee.name=BlackBerry JRE 4.6 0 or what ever you want to install JRE

 

Step 4. After Editing BlackBerry.ee File Add That File to the Eclipse

 

Installing Step for BlackBerry.ee File and  Change JRE of Project

 

Step 1. Go to Windows-->Preferences-->java-->installed jre

Step 2. Click on the Add Button,one Dialog screen Appear click on the BB Execution Environment VM. Step 3 .Click On File button to open Edited BlackBerry.ee File ..

Step 4. Click on Next or Finish Button will add JRE To your Eclipse.. To change the JRE Just Click on the Run Configuration and Click on the Tab JRE And Choose the Alternate JRE which you want to select for your Project..


Please mark posts as solved if you found a solution.
Feel free to press the kudos button to thank the user that helped you
Please use plain text.
Contributor
mvonkdahvo
Posts: 14
Registered: ‎05-17-2010
My Device: 9780
My Carrier: Vodafone

Re: using different JRE

Thanks! This did the trick for me!

Please use plain text.
New Contributor
revnoah
Posts: 2
Registered: ‎04-20-2011
My Device: Curve 8130
My Carrier: Rogers

Re: using different JRE

They changed the update address to http://www.blackberry.com/go/eclipseUpdate/3.6/java 

 

Please use plain text.
Trusted Contributor
shea08
Posts: 118
Registered: ‎03-25-2009
My Device: Z30
My Carrier: Telus

Re: using different JRE

I can't get installation through eclipse to work.  It stalls at 37% of the download on the 4.5 jre, and the 5.0 jre.

 

I tried downloading the 5.0 jde, but it does not have a .ee file. Do I have manually create a .ee file!?

Please use plain text.
Trusted Contributor
shea08
Posts: 118
Registered: ‎03-25-2009
My Device: Z30
My Carrier: Telus

Re: using different JRE

[ Edited ]

I can confirm manually editing the .ee file for both 4.5 and 5.0 work with the eclipse 1.3 plugin.

 

Just downloaded the JDE for the JRE you want. Install it.  Then copy the Blackberry.ee from your eclipse/plugin/componantpack6 (or something like that) into the base of the JDE install.  Then edit the new .ee file to conform to the JDE you downloaded.  All I did was change 6.0.0.xxx to 5.0.0, and 4.5.0, etc.

 

Hope this saves someone else the agony... and gets me kudos.

Please use plain text.