Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
New Developer
arun160411
Posts: 3
Registered: ‎10-09-2008
My Device: Not Specified

why doesn't video is getting played on blackberry

Hi, im a j2me developer and i've written a code which downloads a video from link and shows up. the code is written in j2me MMAPI and it is working fine in normal J2me devices. but the same code base when putting in blackberry 8130. it is not working. it is not displaying the video nor the sound. can any body please answer me why this happens. 1) i tried by "player" class in MMAPI, then just blackscreen is coming up. 2) i tried by platformrequest() method. in this case blackberry browser opens up showing all the freaky characters but not the video. can you suggest me on what needs to be required??Do i need to use blackberry specific API and invoke blackberry native media player? in that case how does the signing happens for that? can i get trail signatures from RIM??whats the procedure.. please do respond. this is urgent for us.
Please use plain text.
Administrator
MSohm
Posts: 14,310
Registered: ‎07-09-2008
My Device: BlackBerry Z30, BlackBerry PlayBook
My Carrier: Bell

Re: why doesn't video is getting played on blackberry

If you are not able to play the video within the BlackBerry Browser, you won't be able to play it using the Player class.

 

Please verify that the video format you are using is supported by the version of BlackBerry handheld software you are testing on.  You can find this under Options, About on the BlackBerry handheld.

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
Please use plain text.