If you are using Internet Explorer, please remove blackberry.com from your compatibility view settings.

Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Contributor
mindon
Posts: 15
Registered: ‎11-01-2012
My Device: Blackberry 10
My Carrier: RIM
Accepted Solution

10.2 Gold: libpng error: bad parameters to zlib

[ Edited ]

10.2 IDE before the Gold version, everything works fine.

 

libpng error: bad parameters to zlib

 

Now with the Gold:

---------------

1. Using 10.1 SDK works fine in OS 10.1

2. Using 10.1 or 10.2 SDK sucks in OS 10.2 Gold.

3. The app complied with 10.1 IDE & SDK works fine in OS 10.2 Gold.

 

Everything works fine under OS 10.2.0.341, but NOT under 10.2.0.1157

 

 

Before the Gold:

---------------

1. 10.2 beta IDE with 10.1 SDK works fine in OS 10.2 beta.

 

 

How to fix this?

Please use plain text.
BlackBerry Development Advisor
PBernhardt
Posts: 749
Registered: ‎12-16-2008
My Device: BlackBerry Z30
My Carrier: Bell

Re: 10.2 Gold: libpng error: bad parameters to zlib

Can you provide more information? What exactly are you trying to do? What is not working?

Paul Bernhardt
Application Development Consultant
BlackBerry
@PBernhardt

Did this answer your question? Please accept this post as the solution.
Found a bug? Report it to the Developer Issue Tracker
Please use plain text.
Contributor
mindon
Posts: 15
Registered: ‎11-01-2012
My Device: Blackberry 10
My Carrier: RIM

Re: 10.2 Gold: libpng error: bad parameters to zlib

Every png in both the QML & ActionBar's system item, ... nothing is displayed, even the ... [displayed as more text]

Please use plain text.
Trusted Contributor
marcelnijman
Posts: 117
Registered: ‎06-19-2012
My Device: PlayBook + Red Z10 + BB10 Dev Alpha C
My Carrier: none

Re: 10.2 Gold: libpng error: bad parameters to zlib

Please install Chess-wise on 10.2 Gold and compare to 10.0 or 10.1. The app is fully functional, but on 10.2, all the images are gone, including the system images like the carrot on the back button and the three vertical dots for the overflow menu. This is a serious bug in 10.2.

Please use plain text.
Trusted Contributor
marcelnijman
Posts: 117
Registered: ‎06-19-2012
My Device: PlayBook + Red Z10 + BB10 Dev Alpha C
My Carrier: none

Re: 10.2 Gold: libpng error: bad parameters to zlib

In my case, it turned out not to be a bug in the OS. I had included the sources of zlib in my project. Until 10.2 Beta this worked fine. With 10.2 Gold, it gave the mentioned error message, because 10.2 Gold links to a newer version of libpng which apparently doesn't cooperate with older versions of zlib. Removing the zlib sources from my project solved the problem. I would say there is a fair chance that this also applies to your case.

Please use plain text.
Developer
AVPTI
Posts: 64
Registered: ‎06-28-2011
My Device: BlackBerry Z10
My Carrier: Bell

Re: 10.2 Gold: libpng error: bad parameters to zlib

Would it be possible to get a little more explanation on this?

 

I am trying to add an image to an ActionItem and the image is sourced properly, but does not appear.

 

I get the following error in the console

 

libpng warning: iCCP: known incorrect sRGB profile

Please use plain text.
BlackBerry Development Advisor
PBernhardt
Posts: 749
Registered: ‎12-16-2008
My Device: BlackBerry Z30
My Carrier: Bell

Re: 10.2 Gold: libpng error: bad parameters to zlib

Unless you are also linking your own version of libpng, it's likely a different issue.

Paul Bernhardt
Application Development Consultant
BlackBerry
@PBernhardt

Did this answer your question? Please accept this post as the solution.
Found a bug? Report it to the Developer Issue Tracker
Please use plain text.
Trusted Contributor
marcelnijman
Posts: 117
Registered: ‎06-19-2012
My Device: PlayBook + Red Z10 + BB10 Dev Alpha C
My Carrier: none

Re: 10.2 Gold: libpng error: bad parameters to zlib

I agree that this is a different issue. I had this once and could solve it by opening the image in an image editor and saving it again. Probably, the original image was created by a program that doesn't quite use the correct header format.

Please use plain text.
Developer
AVPTI
Posts: 64
Registered: ‎06-28-2011
My Device: BlackBerry Z10
My Carrier: Bell

Re: 10.2 Gold: libpng error: bad parameters to zlib

I have tried resaving the image, but still nothing and still get that error.

Please use plain text.
Trusted Contributor
marcelnijman
Posts: 117
Registered: ‎06-19-2012
My Device: PlayBook + Red Z10 + BB10 Dev Alpha C
My Carrier: none

Re: 10.2 Gold: libpng error: bad parameters to zlib

Actually, it's a warning, not an error. What happens if you try a different image? Just to rule out any other cause.

Please use plain text.