Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Developer
Posts: 84
Registered: ‎12-01-2012
My Device: 9790

Re: App Crashes in Device-Release but works in Device-Debug

slogger won't solve the issue - you need to go through your code - probably comment out some parts and locate the issue.

Lublin BlackBerry Developer Group


---
If I helped you please mark my response as solution or "Like" it.
Developer
Posts: 109
Registered: ‎01-27-2012
My Device: Z10 + PlayBook 64GB

Re: App Crashes in Device-Release but works in Device-Debug

Hi,

 

Did the author of the post find a solution?

 

I have (almost) the same problem and I don't know how to solve it. It happens I was creating my release-device version of a new app and I just can't publish it :Oops:

_______________________________________________________
--- Catalonia, next state in Europe ----
Use the "solved" or "Like" icons if my answer helped you.

BES10 administrator for several customers.
"SMPTE Calculator" timecode APP developer for BB10
Developer
Posts: 109
Registered: ‎01-27-2012
My Device: Z10 + PlayBook 64GB

Re: App Crashes in Device-Release but works in Device-Debug

[ Edited ]

Solved!

I did not find de cause, actually. What I did was copy the whole project, but the bar descriptor xml file.
Also rewrite all the code about Scenecover/active frames, because docs were updated from blackberry at 12th june and I was not using the same method.

Thanks

_______________________________________________________
--- Catalonia, next state in Europe ----
Use the "solved" or "Like" icons if my answer helped you.

BES10 administrator for several customers.
"SMPTE Calculator" timecode APP developer for BB10
Regular Contributor
Posts: 60
Registered: ‎06-08-2012
My Device: 8900,9550

Re: App Crashes in Device-Release but works in Device-Debug

Please check the Boolean variables and any objects deleting positions

Contributor
Posts: 15
Registered: ‎08-09-2013
My Device: Developer

Re: App Crashes in Device-Release but works in Device-Debug

you want to try the app you made, in the finish mode?

why are you try load the app in a mode Release-debbug? 

Developer
Posts: 541
Registered: ‎05-17-2009
My Device: Not Specified

Re: App Crashes in Device-Release but works in Device-Debug

These bugs usually have to do with memory management.

 

The most common cause of this error that I have seen is not setting a pointer to NULL or instantiating a pointer before using it in some way. The reason that the error does not occur in device-debug, is because debug mode allocates memory differently than device-release - it seems device-debug will automatically assign NULL to a pointer as a default.