Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Contributor
Posts: 17
Registered: ‎08-01-2012
My Device: Blackberry 10 Alpha Device
My Carrier: None
Accepted Solution

App packaged/released with 2.0.1 NDK not starting

Hi All!

Has anybody experienced such issue:

Application was compiled by NDK 2.0.1 and release version exported using Eclipse -> File -> Export GUI. The resulting BAR file was published to App World. After 10 (looks like) days, users who purchased application started complaining that it is not starting up (splash screen appears and app exits afterwards). Even those users who just bought application and started it for the first time have the same problem. It was perfectly working before some misterious deadline. Reinstallation of application did not help, as well as device rebooting.

Could it be the problem with app signature/certificate which suddenly expired (looks like the only possible problem)? What could go wrong (at which stage) and how to avoid it in the future?

I will appreciate any help very much!
Developer
Posts: 1,068
Registered: ‎11-24-2011
My Device: PlayBook
My Carrier: x

Re: App packaged/released with 2.0.1 NDK not starting

What if you reinstall your app from AppWorld, does it properly start on your PB?

Contributor
Posts: 17
Registered: ‎08-01-2012
My Device: Blackberry 10 Alpha Device
My Carrier: None

Re: App packaged/released with 2.0.1 NDK not starting

No. Users were trying to do reinstall, it did not help. Even new, who just purchased application, are getting the same behavior after first install: application shows splash screen and exits.

Retired
Posts: 329
Registered: ‎05-07-2012
My Device: BB Alpha
My Carrier: N/A

Re: App packaged/released with 2.0.1 NDK not starting

Do you know if this App still works for some users? Could it be that users with the broken App performed a specific update to their device?

 

Martin

 

Contributor
Posts: 17
Registered: ‎08-01-2012
My Device: Blackberry 10 Alpha Device
My Carrier: None

Re: App packaged/released with 2.0.1 NDK not starting

[ Edited ]

I finally got to my dev. system and devices, so got more information on this subject:

 

- I have BAR which was submitted to App World and installed it using QNX Momentix IDE on my dev. device. Earlier this package worked well and also passed certification.

 

- If dev. device has current date (4. September) then when I press app icon to start it, the splash screen appears and stays for about 60 seconds then splash screen disapears and such message is popped up:

 

"Application did not open a window within the allotted time and has been slayed"

 

- if I modify date to some past, like 4. July, application starts right away and is working well

 

I am using Dev Alpha but the same is reported for standard PlayBooks by ALL users who got application installed. It looks like global expiry. Could it be due to wrong app signature?

 

Do you know if this App still works for some users? Could it be that users with the broken App performed a specific update to their device?

 

No they did not do anything specific, some say that no changes were made at all, like new app installation/updates. The package is somehow bound to some period of time that is confirmed by my tests with changing the date on device.

 

Best regards,

Dmitry.

Retired
Posts: 329
Registered: ‎05-07-2012
My Device: BB Alpha
My Carrier: N/A

Re: App packaged/released with 2.0.1 NDK not starting

That's odd. Are you able to reproduce on your own device? If so, does a fresh rebuild push back the date? When does your debug token expire?

 

Martin

 

Contributor
Posts: 17
Registered: ‎08-01-2012
My Device: Blackberry 10 Alpha Device
My Carrier: None

Re: App packaged/released with 2.0.1 NDK not starting

Today I made another release and now it works okay. Changing dates on device does not cause that strange behavior with application not starting up. Let's assume that problem is solved y itself somehow :Sweatdrop:

Retired
Posts: 329
Registered: ‎05-07-2012
My Device: BB Alpha
My Carrier: N/A

Re: App packaged/released with 2.0.1 NDK not starting

Ok, flag it if you run into it again;

 

Martin