Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
New Developer
Thalion
Posts: 10
Registered: ‎09-30-2012
My Device: Bold 9900
My Carrier: Plus

App release SDK version (Gold or 10.1.0.338)

I have recently updated my App  (Daily. The News Reader) to support 720x720 resolution, now I want to build version for the release and upload update into the BlackBerry World.

 

Which sdk I should use to build App version for the release?

Gold 10.1.0.1673 or 10.1.0.338


The second sdk is Beta version, but this sdk introduced support for BlackBerry devices with smaller 720x720 screens.

 

Thanks in advance.

 

 

Please use plain text.
Developer
borceg
Posts: 670
Registered: ‎03-21-2012
My Device: BlackBerry PlayBook 16GB
My Carrier: Vip

Re: App release SDK version (Gold or 10.1.0.338)

SDK 10.1.0.338 for 720x720 support
Please use plain text.
New Developer
Thalion
Posts: 10
Registered: ‎09-30-2012
My Device: Bold 9900
My Carrier: Plus

Re: App release SDK version (Gold or 10.1.0.338)

App build under this sdk (10.1.0.338) will work well on z10 as build on Gold sdk?

Please use plain text.
Developer
borceg
Posts: 670
Registered: ‎03-21-2012
My Device: BlackBerry PlayBook 16GB
My Carrier: Vip

Re: App release SDK version (Gold or 10.1.0.338)

Please use plain text.
Regular Contributor
Transcendental_Mobile
Posts: 94
Registered: ‎04-07-2011
My Device: PlayBook
My Carrier: QED

Re: App release SDK version (Gold or 10.1.0.338)


borceg wrote:
I don't think so. https://developer.blackberry.com/cascades/download/releasenotes_beta_10_1/

IIRC, the info provided by BlackBerry for the new Beta 1 Native IDE is contradictory, and confusing.

 

It's stated that builds won't work on the Z10 (again, this assertion is from my memory), but when you drill down to the next page (or the release notes?) it's stated that the Z10 (and well as the Q10, of course) IS supported IF you install a Z10 SDK edition in the IDE.

 

It would be nice to read something definitive from BlackBerry.

Please use plain text.
Developer
Curahee
Posts: 210
Registered: ‎01-12-2013
My Device: z30
My Carrier: Mobile Vikings

Re: App release SDK version (Gold or 10.1.0.338)

[ Edited ]

I removed the old SDK and only installed the new 10.1 SDK. It works fine in both the Z10 simulator and the Q10 simulator. And also, you need the new features of the 10.1 SDK because you need asset selection when building 1 app for both the Z10 and the Q10. Therefore, you need the 10.1 SDK, impossible to do so with the gold sdk.

______________________________________________________
beRail: BlackBerry World - GitHub
Mobile Vikings: BlackBerry World - GitHub
Park in Brussels: BlackBerry World
Please use plain text.
Developer
Ebscer
Posts: 843
Registered: ‎08-31-2009
My Device: 9530, 9630, 9800, 8530, 9900, 9810, 9930, PlayBook, Dev Alpha
My Carrier: Verizon

Re: App release SDK version (Gold or 10.1.0.338)

Using the 10.1 SDK I have apps apparently running just fine on the Dev Alpha and the full touch simulator. Is this by design or am I getting lucky? It looks to work, but a gurantee would be nice to have...


Read my thoughts on BlackBerry Development at news.ebscer.com
Please use plain text.
Developer
kylefowler
Posts: 526
Registered: ‎05-17-2009
My Device: 9900
My Carrier: ATT

Re: App release SDK version (Gold or 10.1.0.338)

If you try and use any features from the 10.1 sdk and put it on a Z10 it will not work. You need to build with the SDK that you are going to release with. You could technically build with the 10.1 sdk if you arent using any things with dependencies but to be safe you should just build with the Gold sdk. 

Like all of my posts
Please use plain text.
New Developer
Thalion
Posts: 10
Registered: ‎09-30-2012
My Device: Bold 9900
My Carrier: Plus

Re: App release SDK version (Gold or 10.1.0.338)

So I have to build the app with Gold SDK for z10 (and Dev Alpha), and then build other app file for q10 (and Alpha C) with Beta .338 SDK, to be sure that it will work fine on these devices?

Please use plain text.
Developer
kylefowler
Posts: 526
Registered: ‎05-17-2009
My Device: 9900
My Carrier: ATT

Re: App release SDK version (Gold or 10.1.0.338)

you dont HAVE to, but if you use things like keyboard shortcuts you will need to have two different code branches since the Z10 doesnt support 10.1 yet.
Like all of my posts
Please use plain text.