Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Developer
Posts: 123
Registered: ‎01-11-2013
My Device: BlackBerry z10
Accepted Solution

Apps which are working in 10.1 os are not working in updated 10.2

Hello developers,

                         I am experiencing a strange behaviour.I have developed an application in 10.1 SDK.But when i install it on 10.2 device or simulator it crashes.As per my thinking it should work on 10.2 OS vesrion because i have developed in lower version.I have tried to find out but doesnt found satisfactorry solution.Pls help...

Developer
Posts: 932
Registered: ‎03-20-2013
My Device: Red LE Developer Z10

Re: Apps which are working in 10.1 os are not working in updated 10.2

You aren't giving us much to go on. Yes, if you built your app with a 10.1 SDK it should run fine on 10.2, but it is possible you were doing something "illegal" or "unsupported" all along, and were just lucky to get away with it on BB10.1.

 

Can you tell us more about what your app is trying to do when it crashes?


CapQNX wrote:

Hello developers,

                         I am experiencing a strange behaviour.I have developed an application in 10.1 SDK.But when i install it on 10.2 device or simulator it crashes.As per my thinking it should work on 10.2 OS vesrion because i have developed in lower version.I have tried to find out but doesnt found satisfactorry solution.Pls help...






Developer of Built for BlackBerry certified multiFEED RSS/Atom feed reader and aggregator.
Developer
Posts: 123
Registered: ‎01-11-2013
My Device: BlackBerry z10

Re: Apps which are working in 10.1 os are not working in updated 10.2

Actually I have developed an app which has in-app purchase service. Which is working fine in my dev alpha  z10 (10.1 OS).But not working in z30 (10.2 OS) device.

Developer
Posts: 932
Registered: ‎03-20-2013
My Device: Red LE Developer Z10

Re: Apps which are working in 10.1 os are not working in updated 10.2

Does it ever get past the splash screen? Is so, is it always crashing at the same point? Have you tried using the post-mortem debugger to figure what module the app is crashing in?


CapQNX wrote:

Actually I have developed an app which has in-app purchase service. Which is working fine in my dev alpha  z10 (10.1 OS).But not working in z30 (10.2 OS) device.






Developer of Built for BlackBerry certified multiFEED RSS/Atom feed reader and aggregator.
Developer
Posts: 123
Registered: ‎01-11-2013
My Device: BlackBerry z10

Re: Apps which are working in 10.1 os are not working in updated 10.2

Application launching... Its not crashing any where..

 

But In-App purchasing not working in 10.2 OS.

 

there is no any error in console.

Developer
Posts: 6,145
Registered: ‎07-05-2012
My Device: Playbook, Dev Alpha C, Z10 LE, Z30

Re: Apps which are working in 10.1 os are not working in updated 10.2

Can you describe what results you get from your debugging attempts so far?

 

If you've got as far as identifying the piece of code that is actually responsible from either setting breakpoints, stepping through code or console messages then post it here.

 


If you've been helped click on Like Button, if you've been saved buy the app. :smileyhappy:

Developer of stokLocker, Sympatico and Super Sentences.
Developer
Posts: 123
Registered: ‎01-11-2013
My Device: BlackBerry z10

Re: Apps which are working in 10.1 os are not working in updated 10.2

[ Edited ]

Actually problem was this    paymentservice_set_connection_mode(true); line..

 

I remove that line and problem solved...

 

  paymentservice_set_connection_mode(true);