Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Contributor
lvandyk
Posts: 19
Registered: ‎07-17-2012
My Device: BB 10 Alpha Device
Accepted Solution

BAD_FRAME Console Spam

Whenever I perform any actions in the simulator my console gets spammed with messages like so:

 

### BAD_FRAME pid=34803824 at 5697794 ms -> t: 22 ms p1: 0 ms, r: 18 ms, p2: 0 ms, u: 3 ms
### BAD_FRAME pid=34803824 at 5697818 ms -> t: 23 ms p1: 0 ms, r: 19 ms, p2: 0 ms, u: 3 ms
### BAD_FRAME pid=34803824 at 5697851 ms -> t: 32 ms p1: 0 ms, r: 26 ms, p2: 0 ms, u: 4 ms
### BAD_FRAME pid=34803824 at 5697877 ms -> t: 25 ms p1: 0 ms, r: 19 ms, p2: 0 ms, u: 5 ms

 

Is there a way of disabling this?

 

More importantly, is it because I am doing something wrong? Everything works perfectly within my application.

 

This only started once I converted to BETA 2.

 

Thanks!

Developer
blackqtcoder
Posts: 146
Registered: ‎05-18-2012
My Device: PlayBook & STL100-1 LE Z10 & Dev Alpha C

Re: BAD_FRAME Console Spam

The same

---------------------------------------------------------------
Leandro Cerdan - Duantox Apps
BlackBerry Elite dev
TapyHold, Built for Blackberry multimedia scrapbook
Developer
Neurocode
Posts: 43
Registered: ‎12-16-2011
My Device: Torch 9800 & Playbook

Re: BAD_FRAME Console Spam

I also get this, both with sample apps and my own.
regards

Daniel - Neurocode
If my posts help, please click the Like button.

gymChronicles - helping you to keep motivated
Developer
vingilot
Posts: 224
Registered: ‎03-29-2012
My Device: 9900

Re: BAD_FRAME Console Spam

my situation is the same, I know just saying I have the same problem isn't helping anything but it will keep the thread active and hopefully someone knowledgable on this subject can resolve the issue for us.

New Contributor
bb2cool
Posts: 4
Registered: ‎07-12-2012
My Device: Torch

Re: BAD_FRAME Console Spam

I have the same problem. I am ignoring it :-)
Developer
soaman
Posts: 849
Registered: ‎03-03-2011
My Device: Z10

Re: BAD_FRAME Console Spam

I would like to know, too.
--------------------------------------------------------------------------------------
Leader of Ljubljana BlackBerry Developer Group
BlackBerry Certified Builder for Native Application Development
Developer
iamjay
Posts: 18
Registered: ‎04-28-2012
My Device: Playbook & Dev Alpha

Re: BAD_FRAME Console Spam

Not just simulator. This happens on Dev Alpha device also.
Developer
blackqtcoder
Posts: 146
Registered: ‎05-18-2012
My Device: PlayBook & STL100-1 LE Z10 & Dev Alpha C

Re: BAD_FRAME Console Spam

Dou you view this errors in console, too ?

 

---------------------------------------------------------------------

ERROR:: QNXPpsSubscriptionServer: QNXPpsSubscriptionServer::createObject: (13) Failed to create dir /pps/services/automation/framework

ERROR:: QNXPpsSubscriptionServer: QNXPpsSubscriptionServer::subscribe: Failed to open /pps/services/automation/framework/control?delta,notify=492:00000001

 

Context: Failed to find target node with id  0

---------------------------------------------------------------------

 

Tested with StampCollector sample.

---------------------------------------------------------------
Leandro Cerdan - Duantox Apps
BlackBerry Elite dev
TapyHold, Built for Blackberry multimedia scrapbook
Developer
vingilot
Posts: 224
Registered: ‎03-29-2012
My Device: 9900

Re: BAD_FRAME Console Spam

I have had my share of fail to find target nodes, yes, any clarification on what that means as well would be quite useful.

BlackBerry Development Advisor (Retired)
danielrr5
Posts: 32
Registered: ‎05-09-2012
My Device: BB10

Re: BAD_FRAME Console Spam

Hi everyone, 

 

I asked internally and I've been told these are just junk messages that should not be output to the console. They will be removed in a future release of the OS.

 

So don't worry about it for now, they are not related to your app.

 

Regards, 

Daniel