Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
New Member
Sfiet_Konstantin
Posts: 2
Registered: ‎12-12-2012
My Device: BB10 Simulator (:D)

BB10 Simulator Gold: screen not starting

Hello everybody, I recently started working with BB10 NDK in order to develop some nice applications for Qt, but did not get the full potential of the simulator, since I do not have any Dev Alpha. I'm currently using NDK Gold. The problem is that, when running safe mode, everything is rather alright, but I cannot dezoom the UI using ves-zoom or the controller, and with the "normal" mode, the "screen" service do not start. I'm using a Linux Debian Wheezy 64 bits, running on a Lenovo X200, Intel graphics card (i945), with HW acceleration supported (no error when launching VMWare player). Everything _should_ work, but it do not work ... What is wrong with my setup ? Or with the NDK ?
BlackBerry Development Advisor
daryl_martin
Posts: 118
Registered: ‎11-01-2011
My Device: N/A

Re: BB10 Simulator Gold: screen not starting

There is currently no support for zoom while in safe mode, but we are looking to add support in the future. 

 

With regards to your graphics card, I would recommend you update your drivers to the latest version provided by Intel.  If the simulator is stopping at "screen" then VMWare is not detecting your graphics card as being compatible for 3D acceleration.

New Member
Sfiet_Konstantin
Posts: 2
Registered: ‎12-12-2012
My Device: BB10 Simulator (:D)

Re: BB10 Simulator Gold: screen not starting

Well, that's rather strange. I have updated my drivers to the latest drivers provided by debian testing (that should be pretty recent). I have searched the internet to find info about how VMWare support 3D acceleration, and if it do not detect it, it should output a warning. Sadly I do not get anything ... Strange ... Anyway, thanks for your answer. The BB10 safe mode is nearly enough for me from now. I will consider using a more powerful computer (dedicated GPU) for OpenGL apps.