Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Developer
d3v3l0p3r
Posts: 167
Registered: ‎07-19-2012
My Device: Q5, Q10, Z10, Z30, PlayBook
My Carrier: Carrier

Beta 4 - IDE keeps quitting on its own!

Windows 7 x64 --- 8GB RAM

Beta 3 uninstalled completely

installed Beta 4 as a fresh install

 

IDE keeps just quitting on me at random times, sometimes as response to an action and sometimes without even touching it. 

 

is it just me??

---
If you find my post helpful please "like" it and "accept as a solution"
Please use plain text.
Trusted Contributor
georg22
Posts: 245
Registered: ‎11-22-2011
My Device: Blackberry Playbook
My Carrier: vodafone

Re: Beta 4 - IDE keeps quitting on its own!

I have not installed Beta 4 so far but i have had the same issue with Beta 3. I am not sure about the reason but it is almost gone when i stopped closing a running app by swiping on the device. I close the current app via the ide now. Hope it helps.

Please use plain text.
Developer
yogeshwarp
Posts: 30
Registered: ‎11-09-2012
My Device: Dev Alpha A
My Carrier: Airtel

Re: Beta 4 - IDE keeps quitting on its own!

I had that issue with beta 3 till I changed qde.ini to following

bumped up line

-XX:MaxPermSize=128m to

-XX:MaxPermSize=512m

 

Also turned off QML preview and crashes were gone. I think QML previewer is prone to crash which is also mentioned in release notes of beta 4. other settings might be helpful not too sure about that

 

Please use plain text.
Developer
d3v3l0p3r
Posts: 167
Registered: ‎07-19-2012
My Device: Q5, Q10, Z10, Z30, PlayBook
My Carrier: Carrier

Re: Beta 4 - IDE keeps quitting on its own!

I was about to post this that changing to -XX:MaxPermSize=512m and -Xms512M (from 256) helped. 

Forgot had those tuned in my Beta 3 which was still crashing but less frequently ;-)

---
If you find my post helpful please "like" it and "accept as a solution"
Please use plain text.
Developer
d3v3l0p3r
Posts: 167
Registered: ‎07-19-2012
My Device: Q5, Q10, Z10, Z30, PlayBook
My Carrier: Carrier

Re: Beta 4 - IDE keeps quitting on its own!

I posted to eary - still crashes on random actions. I am racing to finish my app before Nov 30 deadline and this is just what I need now... ;-(

---
If you find my post helpful please "like" it and "accept as a solution"
Please use plain text.
Trusted Contributor
georg22
Posts: 245
Registered: ‎11-22-2011
My Device: Blackberry Playbook
My Carrier: vodafone

Re: Beta 4 - IDE keeps quitting on its own!

Oh yes, i can also confirm that QML preview causes crashes. For example when the code inside the creationComplete handlers contains an endless loop or is just not finished while working on it. So i decided to move code i am working on in a separat method and call it from the creationComplete handler when its complete.

Please use plain text.
Developer
yogeshwarp
Posts: 30
Registered: ‎11-09-2012
My Device: Dev Alpha A
My Carrier: Airtel

Re: Beta 4 - IDE keeps quitting on its own!

Did you also try turing off QML Preview? that should help


d3v3l0p3r wrote:

I posted to eary - still crashes on random actions. I am racing to finish my app before Nov 30 deadline and this is just what I need now... ;-(


 

Please use plain text.
Developer
d3v3l0p3r
Posts: 167
Registered: ‎07-19-2012
My Device: Q5, Q10, Z10, Z30, PlayBook
My Carrier: Carrier

Re: Beta 4 - IDE keeps quitting on its own!

Yes its disabled in preferences (although I can still enable it in IDE by turning on split screen - weird)

---
If you find my post helpful please "like" it and "accept as a solution"
Please use plain text.
Developer
d3v3l0p3r
Posts: 167
Registered: ‎07-19-2012
My Device: Q5, Q10, Z10, Z30, PlayBook
My Carrier: Carrier

Re: Beta 4 - IDE keeps quitting on its own!

Spent lots of time trying to resolve it and its taking me nowhere. I tried installing SDK on three different machines:

 

Win 7 64-bit

Win 7 32-bit

Win 8 64-bit

 

and on ALL three machines I am experiencing the same behavior! Essentially I open my project, do some editing and all of suddenly the IDE just dissapears!! 

 

It happens at random times sometimes doing something (clicking, typint, launching app) and sometimes just quits on its own.

 

I even re-downloaded the installation one more time (thinking my install was corrupted) and made no difference.

 

I am really stuck with this - cannot develop at all - very frustrating and counter productive

 

Am I the only one experiencing this??????

---
If you find my post helpful please "like" it and "accept as a solution"
Please use plain text.
Contributor
aldrian
Posts: 43
Registered: ‎01-19-2011
My Device: lets say: I don't own CDMA Variants
My Carrier: T-Mobile Austria

Re: Beta 4 - IDE keeps quitting on its own!

Same here

 

Win7 64-bit

________________
mappau Dev Team
blackberry@mappau.com twitter.com/#!/mappau facebook.com/mappau.at
Please use plain text.