Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
New Member
Posts: 3
Registered: ‎03-10-2013
My Device: Simulator
My Carrier: O2

BlackBerry 10.1 Beta Device Simulator - for Linux

Unfortunately I can not install the simulator. I have no problems with older versions of the simulator.

 

I get this error message under kubuntu 12.04:

 

./BlackBerry10Simulator-Installer-BB10_1_X-807-Linux-201303050726.bin: Zeile 1: ]: Kommando nicht gefunden.
./BlackBerry10Simulator-Installer-BB10_1_X-807-Linux-201303050726.bin: Zeile 274: [: =: Einstelliger (unärer) Operator erwartet.
expr: Argument, das keine Zahl ist
awk: {print $}
awk: ^ syntax error
./BlackBerry10Simulator-Installer-BB10_1_X-807-Linux-201303050726.bin: Zeile 322: [: `)' erwartet, -z gefunden.
WARNING! The amount of /tmp disk space required and/or available
could not be determined. The installation will be attempted anyway.
Extracting the installation resources from the installer archive...
./BlackBerry10Simulator-Installer-BB10_1_X-807-Linux-201303050726.bin: Zeile 605: [: %: Ganzzahliger Ausdruck erwartet.
./BlackBerry10Simulator-Installer-BB10_1_X-807-Linux-201303050726.bin: Zeile 610: [: =: Einstelliger (unärer) Operator erwartet.
cksum: /tmp/install.dir.11821/InstallerData/installer.zip: Datei oder Verzeichnis nicht gefunden
The size of the extracted files to be installed are corrupted. Please
try to download the installer again and make sure that you download
using 'binary' mode.
Please do not attempt to install this currently downloaded copy.

 

Grretings, Bert

 

 

Developer
Posts: 91
Registered: ‎09-25-2012
My Device: bb10 alpha
My Carrier: free

Re: BlackBerry 10.1 Beta Device Simulator - for Linux

Same for me..... It seems the problem comes from the original installer.... ! 

a lover of Qt
Developer
Posts: 91
Registered: ‎09-25-2012
My Device: bb10 alpha
My Carrier: free

Re: BlackBerry 10.1 Beta Device Simulator - for Linux

I posted the bug : 

https://www.blackberry.com/jira/browse/BBTEN-983

a lover of Qt