Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
New Contributor
vaclavmazany
Posts: 4
Registered: ‎11-24-2012
My Device: Developer
My Carrier: Developer

Blackberry IAP issue / doesn't work properly

Recently I got a email from a customer, that he's unable to purchase IAP from my application.

I've tested it on Playbook & Q10, on both it works. The customer has Z10.

 

Here's info from him :

* he's from Canada, but all IAPs are set as worldwide

* device Z10

What happens on his side. When a native username & password dialog for the purchase appears, he writes his name and password, then the dialog disappears. No success nor error is sent back to the application. He tried it several times without a luck.

After about 15days he tried again, and the purchase went well. But the same scenario happens for other IAPs.

 

The app :

http://appworld.blackberry.com/webstore/content/19311604/

 

Any help appreciated.

 

Vaclav

Please use plain text.
Developer
slashkyle
Posts: 814
Registered: ‎10-16-2012
My Device: Red Z10, Dev Alpha C
My Carrier: Telus

Re: Blackberry IAP issue / doesn't work properly

I just downloaded & tested this on my Z10 but was able to see the price on all 3 chapters after entering my info.  and after clicking cancel your custom error screen poped up saying try again later.  

 

Neat game & very nice graphics btw.

Please use plain text.
New Contributor
vaclavmazany
Posts: 4
Registered: ‎11-24-2012
My Device: Developer
My Carrier: Developer

Re: Blackberry IAP issue / doesn't work properly

Thx for testing, that's exactly how it should work. But unfortunately :smileyhappy: this makes me confused even more.

 

Any idea what might be causing that it works for some, and for some it doesn't ?

Or atleast tip on how to test if it's user's fault or IAP implementation.

Please use plain text.
Developer
slashkyle
Posts: 814
Registered: ‎10-16-2012
My Device: Red Z10, Dev Alpha C
My Carrier: Telus

Re: Blackberry IAP issue / doesn't work properly

[ Edited ]

I just implemented IAP myself, the only things I could think of are sparse network connectivity (request stuck between complete and fail leading to no error), or the end user could have maybe thumbnailed the app... other than that I have no ideas other than trying to setup an error code scenario for every possible payment issue

Please use plain text.