Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Developer
Posts: 19
Registered: ‎03-06-2014
My Device: blackberry z10 stl100-3
My Carrier: n/a

Build errors

I had momentics crash on me then fail to start up, so I did a full uninstall/reinstall. I imported my project back and now I get a bunch of unlinked library errors. For instance, it was failing to find <QObject>. I manually imported the library into the project and did a clean rebuild, that fixed that issue but I still have problems linking certain libraries, here's my console:

 

C:\bbndk\host_10_2_0_15\win32\x86\usr\bin\ntoarm-ld: cannot find -lbbgeosearch
C:\bbndk\host_10_2_0_15\win32\x86\usr\bin\ntoarm-ld: cannot find -lBbid
cc: C:/bbndk/host_10_2_0_15/win32/x86/usr/bin/ntoarm-ld caught signal 1
make[2]: *** [o.le-v7-g/TestPOS_BB10] Error 1

 

I found this related post that OSX users were having a similar issue:

http://supportforums.blackberry.com/t5/Native-Development/Problems-building-for-simulator-on-OSX-Lio...

 

but I'm on a windows 7 x86 machine, and their fixes don't work.

Developer
Posts: 19
Registered: ‎03-06-2014
My Device: blackberry z10 stl100-3
My Carrier: n/a

Re: Build errors

I found an annoying work around, instead of importing old projects, I create a new one then manually copy over all the source files and link everything properly under the .pro file.